summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTed Alff2024-01-28 15:26:08 -0500
committerTed Alff2024-01-28 15:26:08 -0500
commitc3a6f85eb37a01946fb79814ff4305ad2f3e9339 (patch)
tree6142b30e19aa19ad2591aee8e0b4dbd017a907c8 /PKGBUILD
parent4e505e94cc3e907676efd38e885adabd9e07727e (diff)
downloadaur-python-screeninfo.tar.gz
Apply micwoj92's build changes to follow guidelines.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bdfa7648f101..c2c33307e791 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=python-screeninfo
pkgver=0.8.1
-pkgrel=1
+pkgrel=2
pkgdesc="Python library to fetch location and size of physical screens"
arch=('any')
url="https://github.com/rr-/screeninfo"
@@ -11,17 +11,17 @@ depends=('python')
optdepends=('libxinerama: xinerama backend'
'libxrandr: randr backend'
'libdrm: experimental DRM backend')
-makedepends=('python-poetry' 'python-pip')
+makedepends=('python-build' 'python-poetry-core' 'python-installer')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/rr-/${pkgname/python-/}/archive/${pkgver}.tar.gz")
sha256sums=('f6b3eeb22196a253611df1d3ee8fff549f2654730823ef4d2533018c27f13b09')
build() {
cd "${srcdir}/${pkgname/python-/}-${pkgver}"
- poetry build -f wheel
+ python -m build --wheel --no-isolation
}
package() {
- PIP_CONFIG_FILE=/dev/null pip install --isolated --root="${pkgdir}" --ignore-installed --no-deps "${pkgname/python-/}-${pkgver}"/dist/*.whl
-
+ cd "${srcdir}/${pkgname/python-/}-${pkgver}"
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dt "${pkgdir}/usr/share/licenses/${pkgname}" -m644 "${srcdir}/${pkgname/python-/}-${pkgver}/LICENSE.md"
}