summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorordoe2015-11-29 13:32:21 +0100
committerordoe2015-11-29 13:32:21 +0100
commitc884883ad7b68709ceea5979ff7f4eea5d252b8c (patch)
tree5905cbe65bb51639a920545bd6753a0f4a59a89c /PKGBUILD
downloadaur-c884883ad7b68709ceea5979ff7f4eea5d252b8c.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ca14a8712dff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Ordoe ordoe <aur@cach.co>
+
+pkgname=python-sense-hat
+pkgver=2.1.0
+pkgrel=1
+pkgdesc="Raspberry Pi Sense HAT Python library"
+arch=('armv7h')
+url="https://pythonhosted.org/sense-hat/"
+license=('BSD')
+depends=('python' 'python-pillow' 'python-setuptools' 'python-numpy' 'python-rtimulib')
+provides=('python-sense-hat')
+source=("https://github.com/RPi-Distro/python-sense-hat/archive/v${pkgver}.tar.gz")
+sha256sums=('fdc26c296955b7b7cca9279e4cbe309b835afbd4912e0b46cbeac20051ff84e5')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+
+ # Install license
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/LICENCE.txt" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}