summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2020-07-03 08:28:35 -0600
committerMark Wagie2020-07-03 08:28:35 -0600
commit064e5432c33e059024cc38392ecab8d6d26464f5 (patch)
treee3e489023e4bc6de26b3356bad857172dad15edf /PKGBUILD
parent4c48cc646f33a21368a9b649f30055ad92f29e1d (diff)
downloadaur-064e5432c33e059024cc38392ecab8d6d26464f5.tar.gz
updated to 0.16.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 14 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4109641c345e..b86866780989 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=python-sentry_sdk
_name=sentry-sdk
-pkgver=0.15.1
+pkgver=0.16.0
pkgrel=1
pkgdesc="The new Python SDK for Sentry.io"
arch=('any')
@@ -9,11 +9,20 @@ url="https://sentry.io/for/python"
license=('BSD')
depends=('python-urllib3' 'python-certifi')
makedepends=('python-setuptools')
-optdepends=('python-flask' 'python-blinker' 'python-bottle' 'python-falcon' 'python-django'
- 'python-sanic' 'python-celery' 'python-beam' 'python-rq' 'python-aiohttp'
- 'python-tornado' 'python-sqlalchemy' 'python-pyspark')
+optdepends=('python-flask: adds support for the Flask Web Framework'
+ 'python-bottle: adds support for the Bottle Web Framework'
+ 'python-falcon: adds support for the Falcon Web Framework'
+ 'python-django: adds support for the Django Web Framework'
+ 'python-sanic: adds support for the Sanic Web Framework'
+ 'python-celery: adds support for the Celery Task Queue System'
+ 'python-apache-beam: experimental BeamIntegration'
+ 'python-rq: adds support for the RQ Job Queue System'
+ 'python-aiohttp: adds support for the AIOHTTP-Server Web Framework'
+ 'python-tornado: adds support for the Tornado Web Framework'
+ 'python-sqlalchemy: captures queries from SQLAlchemy as breadcrumbs'
+ 'python-pyspark: adds support for the Python API for Apache Spark')
source=("https://pypi.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('3ac0c430761b3cb7682ce612151d829f8644bb3830d4e530c75b02ceb745ff49')
+sha256sums=('da06bc3641e81ec2c942f87a0676cd9180044fa3d1697524a0005345997542e2')
build() {
cd "$_name-$pkgver"