summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2022-07-21 08:56:42 -0600
committerMark Wagie2022-07-21 08:56:42 -0600
commitbe421afa84c979b184734a579778c3502b4c2cd8 (patch)
treed4bd4d3b0da37075af5e33039c8a0f4aed1d479a /PKGBUILD
parent5a0d63a4b3526d032c78dd726fdcbcb1ee6488c0 (diff)
downloadaur-be421afa84c979b184734a579778c3502b4c2cd8.tar.gz
1.8.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d72a2f26cee3..b23120310a9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=python-sentry_sdk
_name=sentry-sdk
-pkgver=1.7.2
+pkgver=1.8.0
pkgrel=1
pkgdesc="The new Python SDK for Sentry.io"
arch=('any')
@@ -10,13 +10,13 @@ license=('BSD')
depends=('python-urllib3' 'python-certifi')
makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
optdepends=('python-aiohttp: adds support for the AIOHTTP-Server Web Framework'
- 'python-asgiref: adds support for ASGI'
'python-apache-beam: experimental BeamIntegration'
'python-bottle: adds support for the Bottle Web Framework'
'python-celery: adds support for the Celery Task Queue System'
'python-chalice: for the Chalice web framework for AWS Lambda'\
'python-django: adds support for the Django Web Framework'
'python-falcon: adds support for the Falcon Web Framework'
+ 'python-fastapi: adds support for the FastAPI framework'
'python-flask: adds support for the Flask Web Framework'
'python-httpx: HTTPX integration'
'python-pyramid: adds support for the Pyramid Web Framework'
@@ -25,13 +25,14 @@ optdepends=('python-aiohttp: adds support for the AIOHTTP-Server Web Framework'
'python-redis: adds support for the RQ Job Queue System'
'python-rq: adds support for the RQ Job Queue System'
'python-sanic: adds support for the Sanic Web Framework'
+ 'python-starlette: adds support for the Starlette Framework'
'python-tornado: adds support for the Tornado Web Framework'
'python-trytond: adds support for the Tryton Framework Server'
'python-sqlalchemy: captures queries from SQLAlchemy as breadcrumbs'
'python-pure_eval: for richer stacktraces & additional variables'
'python-executing: for richer stacktraces & better function names')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('95fd321f583dfcfaf279a0b2cdc83d8d28c8b7cca4d2959fc4539bb4fecb56a0')
+sha256sums=('9c68e82f7b1ad78aee6cdef57c2c0f6781ddd9ffa8848f4503c5a8e02b360eea')
build() {
cd "$_name-$pkgver"