summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoryochananmarqos2020-01-17 09:59:03 -0700
committeryochananmarqos2020-01-17 09:59:03 -0700
commitff4f0ef21af3062c5844fbb328cc51164643058e (patch)
tree5c195ba700da425951daca41d44d53666b9acacc /PKGBUILD
parent0a90eef9ada96cad647310909352e39864f2d387 (diff)
downloadaur-ff4f0ef21af3062c5844fbb328cc51164643058e.tar.gz
change source to PyPI
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e5805905cd48..e5a1a4580c6f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=python-sentry_sdk
-_pkgname=sentry-sdk
+_name=sentry-sdk
pkgver=0.14.0
pkgrel=1
pkgdesc="The new Python SDK for Sentry.io"
@@ -12,18 +12,18 @@ makedepends=('python-setuptools')
optdepends=('python-flask' 'python-blinker' 'python-bottle' 'python-falcon' 'python-django'
'python-sanic' 'python-celery' 'python-beam' 'python-rq' 'python-aiohttp'
'python-tornado' 'python-sqlalchemy' 'python-pyspark')
-source=("$url/releases/download/$pkgver/$_pkgname-$pkgver.tar.gz"
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz"
"https://raw.githubusercontent.com/getsentry/sentry-python/master/LICENSE")
sha256sums=('8e2d38dc58dc992280487e553ec3d97a424e4d179f4fad802ef3b08f64ccf4d8'
'59404d4c854e579097d41bfccd5006afde9d6d70e646cf55074cdbfead5ecf1c')
build() {
- cd "$_pkgname-$pkgver"
+ cd "$_name-$pkgver"
python setup.py build
}
package() {
- cd "$_pkgname-$pkgver"
+ cd "$_name-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
install -Dm644 "$srcdir/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname"