summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGrey Christoforo2018-11-27 18:56:41 +0000
committerGrey Christoforo2018-11-27 18:56:41 +0000
commitf8cfdc2c5101d8bbb92744986d6af52d1ef4cf0d (patch)
treecf4ee25a32c41efe6a8184cc6c46c3ccbc099ca6 /PKGBUILD
downloadaur-f8cfdc2c5101d8bbb92744986d6af52d1ef4cf0d.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6f6529152b3e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+pkgname=python-serpent-ai-git
+_module='SerpentAI'
+pkgver=r254.7c66954
+pkgrel=1
+pkgdesc="Game Agent Framework. Helping you create AIs / Bots to play any game you own!"
+url="https://github.com/greyltc/SerpentAI"
+depends=(python opencv python-scikit-image python-xlib python-numpy python-scipy python-h5py-openmpi python-scikit-learn python-crossbar tesseract tesseract-data-eng redis python-aioredis python-kivy python-pyautogui python-autobahn python-editdistance)
+#TODO: python-tesserocr python-mss python-sneakysnek
+makedepends=(python-setuptools)
+license=('MIT')
+arch=('any')
+source=("git://github.com/greyltc/SerpentAI.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_module"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_module}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_module}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}
+