summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2022-04-05 23:10:11 -0500
committerLuis Martinez2022-04-05 23:10:11 -0500
commit7d4439a5153de63ce7f82b4430581a038240153f (patch)
tree8ee7673abf09638af9199ceda4c3f979bc74a8db /PKGBUILD
parent35745aa91dce33a84b63577a22ee0840d80ef0f0 (diff)
downloadaur-7d4439a5153de63ce7f82b4430581a038240153f.tar.gz
update to 0.3.0
* PKGBUILD rewritten
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 24 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6a5949dacd2a..1a7a7778631a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,40 @@
-# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
+
_pkgname=setoptconf
pkgname=python-setoptconf
-pkgver=0.2.0
+pkgver=0.3.0
pkgrel=1
-pkgdesc="A library that can be used to retrieve program settings from a variety of sources"
+pkgdesc="Library for retrieving program settings from various sources"
arch=('any')
url="https://github.com/jayclassless/setoptconf"
license=('MIT')
depends=('python')
-makedepends=('python-setuptools')
-source=(https://github.com/jayclassless/setoptconf/archive/${pkgver}.tar.gz)
-md5sums=('f2a056f7546c9b3a8e0ff6f6e688065d')
+optdepends=('python-pyyaml')
+makedepends=('python-setuptools' 'python-build' 'python-installer' 'python-wheel')
+checkdepends=('python-nose')
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/s/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha256sums=('d2ecbd27c0c7d0d53990e2df98d9aad6490df8b75b71c621d8c441d6e91e3161')
build() {
- cd "${_pkgname}-${pkgver}"
+ cd "$_pkgname-$pkgver"
+ python -m build --wheel --no-isolation
+}
- python setup.py build
+check() {
+ cd "$_pkgname-$pkgver"
+ nosetests
}
package() {
- cd "${_pkgname}-${pkgver}"
+ cd "$_pkgname-$pkgver"
+ PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir/" dist/*.whl
- python setup.py install --prefix="/usr" --root="${pkgdir}" --optimize=1
- install -Dm755 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}"/LICENSE
+ local _site="$(python -c 'import site; print(site.getsitepackages()[0])')"
+ install -d "$pkgdir/usr/share/licenses/$pkgname/"
+ ln -s \
+ "$_site/$_pkgname-$pkgver.dist-info/LICENSE" \
+ "$pkgdir/usr/share/licenses/$pkgname/"
}
+
# vim:set ts=2 sw=2 et: