summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlex Hirzel2023-12-01 10:44:51 -0500
committerAlex Hirzel2023-12-01 10:44:51 -0500
commit086aba28e176d9338f736b44f07b47d990cced8f (patch)
treeb77f82fffb995fa1ffe60cef02aa2e86cc5a6f92 /PKGBUILD
parent507bbebce2e2827ce2039640cad859697c9faeca (diff)
downloadaur-086aba28e176d9338f736b44f07b47d990cced8f.tar.gz
update to version 2.23, use new build/installer mechanisms
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 5 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5a08646332e5..3444afc080c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Alex Hirzel <alex at hirzel period us>
pkgname='python-sgp4'
-_name=${pkgname#python-}
-pkgver='2.22'
+_name="${pkgname#python-}"
+pkgver='2.23'
pkgrel=1
pkgdesc="Track earth satellite TLE orbits using up-to-date 2010 version of SGP4"
url="https://pypi.org/project/sgp4/"
@@ -11,18 +11,15 @@ makedepends=('python-setuptools')
license=('MIT')
arch=('x86_64')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('17f0a2eaad2dca065b6de25c1ceaa940ff7cfa8cc67120cb4111a00f177b86f9')
+sha256sums=('d8addc53a2fb9f88dee6bfd401d2865b014cc0b57bf2cee69bdee8d9685d5429')
build() {
cd "${srcdir}/${_name}-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
- depends+=()
cd "${srcdir}/${_name}-${pkgver}"
install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/$pkgname"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
}
-
-