summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlex Hirzel2022-11-11 13:11:26 -0500
committerAlex Hirzel2022-11-11 13:11:26 -0500
commit4a79180fc1b56cf9e69534d2a6f187d2ecb3d884 (patch)
tree76fb543696a53b13736ff563ac015773e29733fb /PKGBUILD
parent61240ed3f915d3f745215622380c3dd6d259f02e (diff)
downloadaur-4a79180fc1b56cf9e69534d2a6f187d2ecb3d884.tar.gz
fix license and dependency list per namcap warnings, bump pkgrel
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8fd4d3343cfb..4d480b461a9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,10 +3,10 @@
pkgname='python-sgp4'
_name=${pkgname#python-}
pkgver='2.21'
-pkgrel=1
+pkgrel=2
pkgdesc="Track earth satellite TLE orbits using up-to-date 2010 version of SGP4"
url="https://pypi.org/project/sgp4/"
-depends=('python')
+depends=('python-numpy')
makedepends=('python-setuptools')
license=('MIT')
arch=('x86_64')
@@ -21,8 +21,7 @@ build() {
package() {
depends+=()
cd "${srcdir}/${_name}-${pkgver}"
- # waiting for: https://github.com/brandon-rhodes/python-sgp4/issues/74
- #install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/$pkgname"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}