summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlex Hirzel2020-11-26 08:09:13 -0500
committerAlex Hirzel2020-11-26 08:09:13 -0500
commit8c46ebb52527f9cc8cc05caa1c00b07fbf19af3d (patch)
treebfb9c85dc0ee3de33ab61c112f367599537b30d2 /PKGBUILD
parentcdc0acf232cfc1e3f5226b3dc7b26037c8ab91ae (diff)
downloadaur-8c46ebb52527f9cc8cc05caa1c00b07fbf19af3d.tar.gz
respond to namcap warnings
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eda7734b1af5..46cb916178e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
pkgname='python-sgp4'
_name=${pkgname#python-}
pkgver='2.13'
-pkgrel=1
+pkgrel=2
pkgdesc="Track earth satellite TLE orbits using up-to-date 2010 version of SGP4"
url="https://pypi.org/project/sgp4/"
depends=('python')
makedepends=('python-setuptools')
license=('MIT')
-arch=('any')
+arch=('x86_64')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
md5sums=('1e1de8ec0af430174d056a3a53523bac')
@@ -21,6 +21,8 @@ build() {
package() {
depends+=()
cd "${srcdir}/${_name}-${pkgver}"
+ # waiting for: https://github.com/brandon-rhodes/python-sgp4/issues/74
+ #install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}