summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarco Rubin2024-08-22 23:09:37 +0200
committerMarco Rubin2024-08-22 23:09:37 +0200
commit18bba143e034e16edd4059f37dbce748d9c1acca (patch)
treec3942f56f064121a824d54165f6854a96b775d69 /PKGBUILD
parent81eb955124fc2343e26ea8a34b3892f2e496b064 (diff)
downloadaur-18bba143e034e16edd4059f37dbce748d9c1acca.tar.gz
Fix GenericModel import error until upstream adopts pydantic v2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 69c4ce182bb0..85ad4ab37d72 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_name=ShazamIO
pkgname=python-shazamio
pkgver=0.6.0
-pkgrel=2
+pkgrel=3
pkgdesc='Is a asynchronous framework from reverse engineered Shazam API written in Python 3.8+ with asyncio and aiohttp.'
arch=('any')
url='https://github.com/shazamio/ShazamIO'
@@ -25,6 +25,12 @@ makedepends=(python-build python-installer 'python-poetry-core>=1.0.0' 'python-w
source=("$url/archive/$pkgver.tar.gz")
b2sums=('d85c8317d42a5080c2371bc12c0d4d47998ee2fa28b2fb92ffc2117488bc010c3439c7de0f05d970eb5b3f45df013d68aaf76a4f5e6edad0b1fa25f8cd1ca624')
+prepare() {
+ cd $_name-$pkgver
+ sed -i 's/from pydantic.generics import GenericModel//g' shazamio/schemas/base.py
+ sed -i 's/GenericModel, //' shazamio/schemas/base.py
+}
+
build() {
cd $_name-$pkgver
python -m build --wheel --no-isolation