summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorUniversebenzene2019-02-08 00:31:49 +0800
committerUniversebenzene2019-02-08 00:31:49 +0800
commit51c592e28e944e8c947068237fbb606b4da8376f (patch)
treeb143755b7f1f845bace34968d97cd16c5c4d16d6 /PKGBUILD
parent27eceb0127476b3191b673622c08aeebcfda4920 (diff)
downloadaur-51c592e28e944e8c947068237fbb606b4da8376f.tar.gz
Update to version 4.10.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 13 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8cfab8dc9d2b..07a2e2c096b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,29 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgbase=python-sherpa
-pkgname=('python-sherpa' 'python-sherpa-doc')
-pkgver=4.10.1
+_pyname=${pkgbase#python-}
+pkgname=("python-${_pyname}" "python-${_pyname}-doc")
+pkgver=4.10.2
pkgrel=1
pkgdesc="Modeling and fitting package for scientific data analysis"
arch=('i686' 'x86_64')
url="http://cxc.cfa.harvard.edu/contrib/sherpa/"
license=('GPL')
-makedepends=('python>=3.5' 'python-numpy' 'fftw' 'python-setuptools' 'gcc-fortran' 'python-sphinx>=1.3')
-source=("https://files.pythonhosted.org/packages/source/s/sherpa/sherpa-${pkgver}.tar.gz"
+makedepends=('python>=3.5' 'python-numpy' 'fftw' 'python-setuptools' 'python-sphinx>=1.3' 'python-sphinx-astropy' 'graphviz')
+#'gcc-fortran')
+source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz"
'sherpa_local_fftw.patch')
-md5sums=('28137b797633670373e6d729c8d02501'
+md5sums=('2698c62776f0ce793ebc87df7f679065'
'd1823cc7683442d92450fadff7aed362')
prepare() {
- cd ${srcdir}/sherpa-${pkgver}
+ cd ${srcdir}/${_pyname}-${pkgver}
patch -Np1 -i "${srcdir}/sherpa_local_fftw.patch"
}
build() {
- unset LDFLAGS
- cd ${srcdir}/sherpa-${pkgver}
+# unset LDFLAGS
+ cd ${srcdir}/${_pyname}-${pkgver}
python setup.py build
msg "Building Docs"
@@ -32,14 +34,14 @@ package_python-sherpa() {
depends=('python>=3.5' 'python-numpy' 'fftw')
optdepends=('python-matplotlib: Graphical output'
'python-astropy: Data I/O support'
- 'ds9-bin: Imaging requires'
+ 'ds9: Imaging requires'
'xpa: Imaging requires'
'python-pytest>=3.3: For testing suite'
'python-mock: For testing suite'
'python-pytest-xvfb: For testing suite'
'python-sherpa-doc: Documentation for Sherpa')
install=python-sherpa.install
- cd ${srcdir}/sherpa-${pkgver}
+ cd ${srcdir}/${_pyname}-${pkgver}
install -D -m644 {README.md,CITATION} -t "${pkgdir}/usr/share/doc/${pkgname}"
install -D -m644 notebooks/SherpaQuickStart.ipynb -t "${pkgdir}/usr/share/doc/${pkgname}/notebooks"
@@ -50,7 +52,7 @@ package_python-sherpa() {
package_python-sherpa-doc() {
pkgdesc="Documentation for Sherpa"
- cd ${srcdir}/sherpa-${pkgver}/build/sphinx
+ cd ${srcdir}/${_pyname}-${pkgver}/build/sphinx
install -d -m755 "${pkgdir}/usr/share/doc/${pkgbase}"
cp -a html "${pkgdir}/usr/share/doc/${pkgbase}"