summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGuillaume Horel2019-08-19 14:24:21 -0400
committerGuillaume Horel2019-08-19 14:24:21 -0400
commit1a6c5d170e268f0ac38bb4b142d9bb6157d68445 (patch)
tree667d1ea4560c4179f539f6829bedb19fd1d99fb3 /PKGBUILD
downloadaur-1a6c5d170e268f0ac38bb4b142d9bb6157d68445.tar.gz
initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c16974fe9753
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+pkgname=('python-skia-pathops')
+_pkgname='skia-pathops'
+pkgver='0.2.0.post2'
+pkgrel=1
+pkgdesc="Python bindings for the Skia library's Path Opts."
+url="https://github.com/googlefonts/fontmak://github.com/fonttools/skia-pathops"
+checkdepends=('python-pytest' 'python-pytest-cython')
+depends=('python')
+makedepends=('cython' 'python-setuptools')
+optdepends=()
+license=('BSD')
+arch=('x86_64')
+source=("https://pypi.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.zip")
+sha256sums=('87ac9513f17944cc27f67a9db393cf1a385e300cb914ad44b82797c1498b4af5')
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}
+
+check() {
+ cd "$srcdir/$_pkgname-${pkgver}"
+ python setup.py build_ext --inplace
+ PYTHONPATH="src/python" pytest
+}