summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlex Hirzel2023-05-03 15:26:46 -0400
committerAlex Hirzel2023-05-03 15:26:46 -0400
commitd0067ee9dfb956745565adad4a1ba6c746b2f6de (patch)
tree249da77cdc6fc4a8dbac3c382d9c2ea8a4b6835c /PKGBUILD
parent0d41e3bce7be5e5b93ba2173b78a82f19354d969 (diff)
downloadaur-d0067ee9dfb956745565adad4a1ba6c746b2f6de.tar.gz
update to version 1.46
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 977db647d8d1..e3c60b456317 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,17 @@
pkgname='python-skyfield'
_name=${pkgname#python-}
-pkgver='1.45'
-pkgrel=2
+pkgver='1.46'
+pkgrel=1
pkgdesc="Elegant astronomy for Python"
url="https://rhodesmill.org/skyfield/"
depends=('ipython' 'python-certifi' 'python-jplephem' 'python-matplotlib' 'python-pandas' 'python-sgp4' 'python-sympy')
makedepends=('python-setuptools')
+checkdepends=('python-mock' 'python-pytz')
license=('MIT')
arch=('any')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('5f0e0530bda6c9bf23a188c574181b4ee63cf2ce1ec1e0c8825f45ae577d8b36')
+sha256sums=('27a54edbc46232a11019bcd88a9b74d36770aff26ff8ee631b90a81ba0be93e4')
build() {
cd "${srcdir}/${_name}-${pkgver}"
@@ -19,7 +20,6 @@ build() {
}
package() {
- depends+=()
cd "${srcdir}/${_name}-${pkgver}"
install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/$pkgname"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build