summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSébastien Leduc2015-06-13 10:51:23 +0200
committerSébastien Leduc2015-06-13 10:51:23 +0200
commita0d396130d09ddbf33f7e447c55d26ff36b06484 (patch)
tree2a5dd0ec9a2edf89f41a775ad4580623f0b0527e /PKGBUILD
downloadaur-a0d396130d09ddbf33f7e447c55d26ff36b06484.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..59355e7ed034
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Sebastien Leduc <sebastien@sleduc.fr
+
+pkgname=python-sleekxmpp
+pkgver=1.3.1
+pkgrel=1
+pkgdesc="A XMPP library written for Python 3.x"
+arch=("any")
+url="http://github.com/fritzy/SleekXMPP"
+license=('MIT')
+depends=('python')
+optdepends=('python-dnspython: SRV support')
+source=("https://pypi.python.org/packages/source/s/sleekxmpp/sleekxmpp-$pkgver.tar.gz")
+md5sums=('ff7c1154fb238efa83ea64ef91a1bff4')
+
+package() {
+ cd "$srcdir/sleekxmpp-$pkgver"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+}