summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorUniversebenzene2019-06-09 18:48:32 +0800
committerUniversebenzene2019-06-09 18:48:32 +0800
commit2e2c167a87e2ea5bff6807ca039a0104cf57fb77 (patch)
treede4b529fb765daec12c1f76360bf58d079430e98 /PKGBUILD
parente59b2f4e26db80c4654bcf31e877d40f3669932e (diff)
downloadaur-2e2c167a87e2ea5bff6807ca039a0104cf57fb77.tar.gz
Update to version 2.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD58
1 files changed, 7 insertions, 51 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 30ee81a4b0a3..c3fa839ab308 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,67 +1,31 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgbase=python-sncosmo
_pyname=${pkgbase#python-}
-pkgname=("python-${_pyname}" "python2-${_pyname}")
-#"python-${_pyname}-doc")
-pkgver=1.8.0
+pkgname=("python-${_pyname}")
+pkgver=2.0.0
pkgrel=1
pkgdesc="Python library for supernova cosmology"
arch=('i686' 'x86_64')
url="https://sncosmo.readthedocs.io/"
license=('BSD')
-makedepends=('python-setuptools' 'python2-setuptools' 'python-numpy' 'python2-numpy')
-#'python-astropy' 'python-extinction' 'python-sphinx-gallery' 'python-iminuit')
+makedepends=('cython' 'python-numpy')
checkdepends=('python-pytest-astropy' 'python-astropy' 'python2-astropy' 'python-extinction' 'python-iminuit')
-#'python2-pytest' 'python2-extinction' 'python-nestle')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('09a3c9100ed1be411e832be2fb18c8d7')
-
-prepare() {
- cd ${srcdir}/${_pyname}-${pkgver}
-
- cp -a ${srcdir}/${_pyname}-${pkgver}{,-py2}
-}
+md5sums=('55dc7e2d5bbfe1da50dd334a5e128cf4')
build() {
- msg "Building Python2"
- cd ${srcdir}/${_pyname}-${pkgver}-py2
- python2 setup.py build
-
- msg "Building Python3"
cd ${srcdir}/${_pyname}-${pkgver}
- python setup.py build
-# msg "Building Docs"
-# python setup.py build_sphinx
+ python setup.py build
}
check() {
-# msg "Checking Python3"
cd ${srcdir}/${_pyname}-${pkgver}
- python setup.py test
-#
-# msg "Checking Python2"
-# cd ${srcdir}/${_pyname}-${pkgver}-py2
-# python2 setup.py test
-}
-
-package_python2-sncosmo() {
- depends=('python2>=2.7' 'python2-astropy' 'python2-extinction')
- optdepends=('python2-matplotlib: For plotting functions'
- 'python2-iminuit: For light curve fitting using the Minuit minimizer in sncosmo.fit_lc'
- 'python2-emcee: For MCMC light curve parameter estimation in sncosmo.mcmc_lc'
- 'python2-nestle: For nested sampling light curve parameter estimation in sncosmo.nest_lc'
- 'python2-corner: For plotting results from the samplers sncosmo.mcmc_lc and sncosmo.nest_lc'
- 'python2-pytest<3.7: For testing'
- 'python-sncosmo-doc: Documentation for SNCosmo')
- cd ${srcdir}/${_pyname}-${pkgver}-py2
- install -D -m644 LICENSE.rst -t "${pkgdir}/usr/share/licenses/${pkgname}"
- install -D -m644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
- python2 setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+ python setup.py test
}
-package_python-sncosmo() {
+package() {
depends=('python>=3.4' 'python-astropy' 'python-extinction')
optdepends=('python-matplotlib: For plotting functions'
'python-iminuit: For light curve fitting using the Minuit minimizer in sncosmo.fit_lc'
@@ -75,11 +39,3 @@ package_python-sncosmo() {
install -D -m644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
}
-
-#package_python-sncosmo-doc() {
-# pkgdesc="Documentation for Python sncosmo module"
-# cd ${srcdir}/${_pyname}-${pkgver}/docs/_build
-#
-# install -d -m755 "${pkgdir}/usr/share/doc/${pkgbase}"
-# cp -a html "${pkgdir}/usr/share/doc/${pkgbase}"
-#}