summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPeter Mattern2017-01-30 23:46:31 +0100
committerPeter Mattern2017-01-30 23:46:31 +0100
commit3ada0bd1c3fb2941fe569f8567a14bb3f0e31b97 (patch)
tree7ab8493ce4f7f0a06c6707c55c6fe59f2fe1bbbf /PKGBUILD
downloadaur-3ada0bd1c3fb2941fe569f8567a14bb3f0e31b97.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ae16fb594b83
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Peter Mattern <pmattern at arcor dot de>
+
+pkgbase=python-social-auth-core
+pkgname=($pkgbase 'python2-social-auth-core')
+pkgver=1.0.1
+pkgrel=1
+pkgdesc='Core component of the python-social-auth ecosystem'
+arch=('any')
+url='https://github.com/python-social-auth/social-core'
+license=('BSD')
+makedepends=('python-setuptools' 'python2-setuptools'
+ 'python-defusedxml' 'python-six' 'python-pyjwt' 'python-requests-oauthlib' 'python-openid'
+ 'python2-defusedxml' 'python2-six' 'python2-pyjwt' 'python2-requests-oauthlib' 'python2-openid')
+source=("$pkgbase-$pkgver.tar.gz::https://github.com/python-social-auth/social-core/archive/$pkgver.tar.gz")
+sha256sums=('becdae55c3d050ec456844f282e6b468df0847b131e615017019ca97b631d972')
+
+prepare() {
+ cp -r social-core-$pkgver social-core-$pkgver-python2
+}
+
+build() {
+
+ cd $srcdir/social-core-$pkgver
+ python setup.py build
+
+ cd $srcdir/social-core-$pkgver-python2
+ python2 setup.py build
+
+}
+
+package_python-social-auth-core() {
+
+ depends=('python-defusedxml' 'python-six' 'python-pyjwt' 'python-requests-oauthlib' 'python-openid')
+
+ cd social-core-$pkgver
+ python setup.py install --root $pkgdir --optimize=1
+
+ install -Dm644 $srcdir/social-core-$pkgver/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+
+}
+
+package_python2-social-auth-core() {
+
+ depends=('python2-defusedxml' 'python2-six' 'python2-pyjwt' 'python2-requests-oauthlib' 'python2-openid')
+
+ cd social-core-$pkgver-python2
+ python2 setup.py install --root $pkgdir --optimize=1
+
+ install -Dm644 $srcdir/social-core-$pkgver-python2/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+
+}