summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPeter Mattern2020-07-04 13:43:24 +0200
committerPeter Mattern2020-07-04 13:43:24 +0200
commit4388f3dfb00ac87ae751687a75539274cdb0d060 (patch)
tree1e109bbe22e9b501e4a5e04079f4e25e962fb1bd /PKGBUILD
parentf6bb392b130d94f1cba3b1f634472a6b0bb3806c (diff)
downloadaur-4388f3dfb00ac87ae751687a75539274cdb0d060.tar.gz
Upstream update: release 3.4.0
This release removes support of Python 2. Meanwhile, the Python 2 versions of too many dependencies were removed from both the official repositories and the AUR.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 10 insertions, 34 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 84319bd716fa..3029a70d86ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,26 @@
# Maintainer: Peter Mattern <pmattern at arcor dot de>
-pkgbase=python-social-auth-core
-pkgname=(${pkgbase} 'python2-social-auth-core')
-pkgver=1.7.0
+pkgname=python-social-auth-core
+pkgver=3.4.0
pkgrel=1
-pkgdesc='Core component of the python-social-auth ecosystem'
+pkgdesc='Python Social Auth core component'
arch=('any')
url='https://github.com/python-social-auth/social-core'
license=('BSD')
-makedepends=('python-setuptools' 'python-defusedxml' 'python-pyjwt' 'python-pyjwkest' 'python-requests-oauthlib'
- 'python-openid' 'python-cryptography' 'python3-saml'
- 'python2-setuptools' 'python2-defusedxml' 'python2-pyjwt' 'python2-pyjwkest' 'python2-requests-oauthlib'
- 'python2-openid' 'python2-cryptography' 'python2-saml')
-source=("${pkgbase}-${pkgver}.tar.gz::https://github.com/python-social-auth/social-core/archive/${pkgver}.tar.gz")
-sha256sums=('c12480159bc7a8ed5d71627103e70cbe8ce63af1bf6f4f1d265d8e9b6c58c39c')
-
-prepare() {
- cp -r social-core-${pkgver} social-core-${pkgver}-python2
-}
+makedepends=('python-six' 'python-defusedxml' 'python-pyjwt' 'python-jose' 'python-requests-oauthlib'
+ 'python-openid' 'python-cryptography' 'python3-saml')
+makedepends=('python-setuptools')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
+sha256sums=('06e137cf87a23bd077541523833b29f481081dd7ee143651b758db701032e606')
build() {
- cd ${srcdir}/social-core-${pkgver}
+ cd social-core-${pkgver}
python setup.py build
- cd ${srcdir}/social-core-${pkgver}-python2
- python2 setup.py build
-
}
-package_python-social-auth-core() {
-
- depends=('python-defusedxml' 'python-pyjwt' 'python-pyjwkest' 'python-requests-oauthlib'
- 'python-openid' 'python-cryptography' 'python3-saml')
+package() {
cd social-core-${pkgver}
python setup.py install --root ${pkgdir} --optimize=1
@@ -40,15 +28,3 @@ package_python-social-auth-core() {
install -Dm644 ${srcdir}/social-core-${pkgver}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
}
-
-package_python2-social-auth-core() {
-
- depends=('python2-defusedxml' 'python2-pyjwt' 'python2-pyjwkest' 'python2-requests-oauthlib'
- 'python2-openid' 'python2-cryptography' 'python2-saml')
-
- cd social-core-${pkgver}-python2
- python2 setup.py install --root ${pkgdir} --optimize=1
-
- install -Dm644 ${srcdir}/social-core-${pkgver}-python2/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
-
-}