summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPeter Mattern2018-08-31 02:50:52 +0200
committerPeter Mattern2018-08-31 02:50:52 +0200
commitf6bb392b130d94f1cba3b1f634472a6b0bb3806c (patch)
tree57e86b5b9572c33d1cb7f88b687ff29b9d8a9ab0 /PKGBUILD
parent3b53398a18034831f6cf6b7de23d2e4c6bd8ae41 (diff)
downloadaur-f6bb392b130d94f1cba3b1f634472a6b0bb3806c.tar.gz
Upstream update: release 1.7.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 21 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4459c7e45c1f..84319bd716fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,51 +1,54 @@
# Maintainer: Peter Mattern <pmattern at arcor dot de>
pkgbase=python-social-auth-core
-pkgname=($pkgbase 'python2-social-auth-core')
-pkgver=1.2.0
+pkgname=(${pkgbase} 'python2-social-auth-core')
+pkgver=1.7.0
pkgrel=1
pkgdesc='Core component of the python-social-auth ecosystem'
arch=('any')
url='https://github.com/python-social-auth/social-core'
license=('BSD')
-makedepends=('python-setuptools' 'python2-setuptools'
- 'python-defusedxml' 'python-six' 'python-pyjwt' 'python-requests-oauthlib' 'python-openid'
- 'python2-defusedxml' 'python2-six' 'python2-pyjwt' 'python2-requests-oauthlib' 'python2-openid')
-source=("$pkgbase-$pkgver.tar.gz::https://github.com/python-social-auth/social-core/archive/$pkgver.tar.gz")
-sha256sums=('e36e86cb950961d106180765c4ffcbc674d1014b8bb233fac5c0493b5cf14d9d')
+makedepends=('python-setuptools' 'python-defusedxml' 'python-pyjwt' 'python-pyjwkest' 'python-requests-oauthlib'
+ 'python-openid' 'python-cryptography' 'python3-saml'
+ 'python2-setuptools' 'python2-defusedxml' 'python2-pyjwt' 'python2-pyjwkest' 'python2-requests-oauthlib'
+ 'python2-openid' 'python2-cryptography' 'python2-saml')
+source=("${pkgbase}-${pkgver}.tar.gz::https://github.com/python-social-auth/social-core/archive/${pkgver}.tar.gz")
+sha256sums=('c12480159bc7a8ed5d71627103e70cbe8ce63af1bf6f4f1d265d8e9b6c58c39c')
prepare() {
- cp -r social-core-$pkgver social-core-$pkgver-python2
+ cp -r social-core-${pkgver} social-core-${pkgver}-python2
}
build() {
- cd $srcdir/social-core-$pkgver
+ cd ${srcdir}/social-core-${pkgver}
python setup.py build
- cd $srcdir/social-core-$pkgver-python2
+ cd ${srcdir}/social-core-${pkgver}-python2
python2 setup.py build
}
package_python-social-auth-core() {
- depends=('python-defusedxml' 'python-six' 'python-pyjwt' 'python-requests-oauthlib' 'python-openid')
+ depends=('python-defusedxml' 'python-pyjwt' 'python-pyjwkest' 'python-requests-oauthlib'
+ 'python-openid' 'python-cryptography' 'python3-saml')
- cd social-core-$pkgver
- python setup.py install --root $pkgdir --optimize=1
+ cd social-core-${pkgver}
+ python setup.py install --root ${pkgdir} --optimize=1
- install -Dm644 $srcdir/social-core-$pkgver/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+ install -Dm644 ${srcdir}/social-core-${pkgver}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
}
package_python2-social-auth-core() {
- depends=('python2-defusedxml' 'python2-six' 'python2-pyjwt' 'python2-requests-oauthlib' 'python2-openid')
+ depends=('python2-defusedxml' 'python2-pyjwt' 'python2-pyjwkest' 'python2-requests-oauthlib'
+ 'python2-openid' 'python2-cryptography' 'python2-saml')
- cd social-core-$pkgver-python2
- python2 setup.py install --root $pkgdir --optimize=1
+ cd social-core-${pkgver}-python2
+ python2 setup.py install --root ${pkgdir} --optimize=1
- install -Dm644 $srcdir/social-core-$pkgver-python2/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+ install -Dm644 ${srcdir}/social-core-${pkgver}-python2/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
}