summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNathan Owens2020-04-29 19:14:18 -0500
committerNathan Owens2020-04-29 19:14:31 -0500
commitd5dacc1f39c052b61dac2f91935511257d8dbb59 (patch)
tree9c099f3af0bd53dc682756bfd04fe7134f9fa311 /PKGBUILD
parent52235d90660b9a6e1431766ae48b9ba3bf56812c (diff)
downloadaur-d5dacc1f39c052b61dac2f91935511257d8dbb59.tar.gz
Update to 0.10.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 9 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 199f1a7d1482..54e250d77342 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,24 @@
# Maintainer: 71e6fd52 <DAStudio.71e6fd52@gmail.com>
+# Maintainer: Nathan Owens <ndowens @ artixlinux.org>
-pkgbase=('python-sockjs')
-pkgname=('python-sockjs')
-_module='sockjs'
-pkgver='0.6.0'
+pkgname=python-sockjs
+pkgver='0.10.0'
pkgrel=1
pkgdesc="SockJS server implementation for aiohttp."
url="https://github.com/aio-libs/sockjs/"
depends=('python')
-makedepends=('python-setuptools')
+makedepends=('python-setuptools' 'git')
license=('Apache')
arch=('any')
-source=("https://files.pythonhosted.org/packages/source/s/sockjs/sockjs-${pkgver}.tar.gz")
-md5sums=('3ef9509c312d34cc2bb1b996330f2e0e')
+source=("git+https://github.com/aio-libs/sockjs#tag=v${pkgver}")
+sha256sums=('SKIP')
build() {
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "$srcdir/sockjs"
python setup.py build
}
package() {
- depends+=()
- cd "${srcdir}/${_module}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ cd "$srcdir/sockjs"
+ python setup.py install --root="${pkgdir}" --optimize=1
}