summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTurtleRuss2024-04-30 05:48:07 +0800
committerTurtleRuss2024-04-30 05:48:07 +0800
commit768db3da4609f0acceed29de31e5f1173f9ec020 (patch)
tree8983fda5a64aa0e5cb1f9525908e5e43a32cb867 /PKGBUILD
parentd5b6abe6976d0e080d003d5aa4843cb8ac27ed8b (diff)
downloadaur-768db3da4609f0acceed29de31e5f1173f9ec020.tar.gz
update to 0.30.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8303ca6fb81a..4cde61db9ca6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,29 @@
-# Maintainer: m8D2 <omui (at) proton mail (dot) com>
+# Maintainer: TurtleRuss <tttturtleruss@gmail.com>
+# Contributor: m8D2 <omui (at) proton mail (dot) com>
# Contributor: novenary <streetwalkermc@gmail.com>
# Contributor: Daniel M. Capella <polyzen@archlinux.org>
pkgname=python-soco
-pkgver=0.28.1
+pkgver=0.30.3
pkgrel=1
pkgdesc="A Python library that allows you to control Sonos speakers programmatically"
arch=('any')
url="https://github.com/SoCo/SoCo"
license=('MIT')
-depends=('python' 'python-requests' 'python-xmltodict' 'python-ifaddr')
-makedepends=('python-setuptools')
+depends=('python' 'python-requests' 'python-xmltodict' 'python-ifaddr' 'python-twisted' 'python-aiohttp' 'python-appdirs' 'python-lxml')
+makedepends=('python-build' 'python-installer')
source=("SoCo-$pkgver.tar.gz::https://github.com/SoCo/SoCo/archive/v$pkgver.tar.gz")
-sha256sums=('012d60b19aeeef87cb2f016c3c08979ef509ac37795f8327b80fcf2078b21f39')
+sha256sums=('SKIP')
build() {
cd SoCo-$pkgver
- python setup.py build
+ python3 -m build
}
package() {
cd SoCo-$pkgver
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 -t "$pkgdir"/usr/share/licenses/$pkgname LICENSE.rst
}