summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilipp A2020-04-28 14:04:02 +0200
committerPhilipp A2020-04-28 14:04:02 +0200
commit7f79fdca6da9169e53e59bcaf9bec82e335a5655 (patch)
treee811293e3cf6f7d9cf9658349850d73b24989fbb /PKGBUILD
downloadaur-7f79fdca6da9169e53e59bcaf9bec82e335a5655.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2845bf82be76
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Philipp A. <flying-sheep@web.de>
+# Contributor: Jonas Heinrich <onny@project-insanity.org>
+
+pkgname=python-soundcard-git
+pkgver=0.3.3.r10.gc03a9f9
+pkgrel=1
+pkgdesc='Play and record audio without resorting to CPython extensions'
+arch=(any)
+url='https://github.com/bastibe/SoundCard'
+license=('BSD3')
+depends=(python python-numpy python-cffi)
+provides=("python-soundcard=$pkgver")
+conflicts=(python-soundcard)
+makedepends=('python-setuptools')
+source=("git+https://github.com/bastibe/SoundCard.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/SoundCard"
+ # 0.3.3 is mistagged
+ git tag -f 0.3.3 3d14b335513290cf8197f54e6c8ca4f353aaa535 >/dev/null
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/SoundCard"
+ python setup.py install --root="$pkgdir"
+}