summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Arndt2022-10-01 09:26:12 +0200
committerChristopher Arndt2022-10-01 09:26:12 +0200
commit955fc25997e26da277322719ba93ddbf0b7c7ca8 (patch)
treeb239c4e7d5519ef36d8938c0e9bf024c2ff50ee9 /PKGBUILD
parentbbeda530636cd309c749f88eadf0cfa19ff1663a (diff)
downloadaur-955fc25997e26da277322719ba93ddbf0b7c7ca8.tar.gz
Switch to PEP-517 installation method
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c4b034fc51a5..bf1f1cd4a3a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,29 +3,30 @@
_name=soundfile
pkgname=python-soundfile
pkgver=0.11.0
-pkgrel=1
+pkgrel=2
pkgdesc='A Python library to read and write audio files using libsndfile, CFFI and NumPy'
url='https://github.com/bastibe/python-soundfile'
arch=(any)
license=(BSD)
-makedepends=(python-setuptools)
+makedepends=(python-build python-installer python-wheel)
depends=(python-cffi libsndfile python-numpy)
+checkdepends=(python-pytest)
source=("https://github.com/bastibe/python-soundfile/releases/download/$pkgver/$_name-$pkgver.tar.gz")
sha256sums=('931738a1c93e8684c2d3e1d514ac63440ce827ec783ea0a2d3e4730e3dc58c18')
build() {
cd $_name-$pkgver
- python setup.py build
+ python -m build --wheel --no-isolation
}
check() {
cd $_name-$pkgver
- python setup.py test
+ pytest -v
}
package() {
cd $_name-$pkgver
- python setup.py install --root="$pkgdir" --skip-build --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
# install license
install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname
}