summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Arndt2022-09-29 19:47:47 +0200
committerChristopher Arndt2022-09-29 19:47:47 +0200
commitbbeda530636cd309c749f88eadf0cfa19ff1663a (patch)
tree69dbda0e95298e71dcaed2f23f8243fb8752aab5 /PKGBUILD
parent113dab7b486ec4c6dc937b41e2a7e433838f190d (diff)
downloadaur-bbeda530636cd309c749f88eadf0cfa19ff1663a.tar.gz
New upstream version 0.11.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 20 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 514bb4e05fea..c4b034fc51a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,31 @@
# Maintainer: Christopher Arndt <aur at chrisarndt dot de>
-_name=SoundFile
+_name=soundfile
pkgname=python-soundfile
-pkgver=0.10.3.post1
-pkgrel=3
-pkgdesc="An audio library based on libsndfile, CFFI and NumPy"
-url="https://github.com/bastibe/python-soundfile"
-arch=('any')
-license=('BSD')
-makedepends=('python-setuptools')
-depends=('python-cffi' 'libsndfile' 'python-numpy')
-source=("https://github.com/bastibe/python-soundfile/releases/download/${pkgver/\.post1/post1}/${_name}-${pkgver}.tar.gz")
-sha256sums=('ffd018d59397a0a4c5327087324ff3620bfd770f7e3eb0cd59779af849e8d861')
-
+pkgver=0.11.0
+pkgrel=1
+pkgdesc='A Python library to read and write audio files using libsndfile, CFFI and NumPy'
+url='https://github.com/bastibe/python-soundfile'
+arch=(any)
+license=(BSD)
+makedepends=(python-setuptools)
+depends=(python-cffi libsndfile python-numpy)
+source=("https://github.com/bastibe/python-soundfile/releases/download/$pkgver/$_name-$pkgver.tar.gz")
+sha256sums=('931738a1c93e8684c2d3e1d514ac63440ce827ec783ea0a2d3e4730e3dc58c18')
build() {
- cd "${srcdir}/${_name}-${pkgver}"
-
+ cd $_name-$pkgver
python setup.py build
}
-package() {
- cd "${srcdir}/${_name}-${pkgver}"
-
- python setup.py install --root="${pkgdir}" --skip-build --optimize=1
+check() {
+ cd $_name-$pkgver
+ python setup.py test
+}
+package() {
+ cd $_name-$pkgver
+ python setup.py install --root="$pkgdir" --skip-build --optimize=1
# install license
- install -Dm644 LICENSE -t "${pkgdir}"/usr/share/licenses/${pkgname}
+ install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname
}