summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Arndt2019-11-07 20:36:01 +0100
committerChristopher Arndt2019-11-07 20:36:01 +0100
commitd32b5d74eb63d94e9dc071dd2affe3207e759cfb (patch)
tree4f5857119b012899b1b972384cecf32b40f55df3 /PKGBUILD
parentd58b3fa7fd5de7d1c264ee37911bb95f04ef0851 (diff)
downloadaur-d32b5d74eb63d94e9dc071dd2affe3207e759cfb.tar.gz
New upstream version 0.10.2
* Adopted package. * Use source distribution from PyPI instead of GitHub. * Install LICENSE file. * Use '--skip-build' option to 'python setup.py install' in 'package' function.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 14 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 74024310f321..8f252a699f05 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,8 @@
+# Maintainer: Christopher Arndt <aur at chrisarndt dot de>
+
+_name=SoundFile
pkgname=python-soundfile
-pkgver=0.10.1
+pkgver=0.10.2
pkgrel=1
pkgdesc="An audio library based on libsndfile, CFFI and NumPy"
url="https://github.com/bastibe/PySoundFile"
@@ -7,17 +10,21 @@ arch=('any')
license=('BSD')
makedepends=('python-setuptools')
depends=('python-cffi' 'libsndfile' 'python-numpy')
-source=("https://github.com/bastibe/PySoundFile/archive/${pkgver}.tar.gz")
-sha256sums=('f53fc58b943827fee60e40ee87c11d1ff21cf6567c65449897371a4019be8c28')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('637f6218c867b8cae80f6989634a0813b416b3e6132480d056e6e5a89a921571')
+
build() {
- cd "${srcdir}"/SoundFile-$pkgver
+ cd "${srcdir}/${_name}-${pkgver}"
+
python setup.py build
}
package() {
- cd "${srcdir}/SoundFile-$pkgver"
- python setup.py install --root=${pkgdir} --optimize=1
-}
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --skip-build --optimize=1
+ # install license
+ install -Dm644 LICENSE -t "${pkgdir}"/usr/share/licenses/${pkgname}
+}