summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2019-06-28 20:40:31 +0200
committerMichel Zou2019-06-28 20:40:31 +0200
commitd58b3fa7fd5de7d1c264ee37911bb95f04ef0851 (patch)
treed4ec6d9c07546159fb4228cbdf81289feeef3117 /PKGBUILD
parenteb47fd2559c78e593ccf08550e47635189694a48 (diff)
downloadaur-d58b3fa7fd5de7d1c264ee37911bb95f04ef0851.tar.gz
drop py2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 4 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 63a44a718d2a..74024310f321 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,23 @@
-pkgbase=python-soundfile
-pkgname=('python-soundfile' 'python2-soundfile')
+pkgname=python-soundfile
pkgver=0.10.1
pkgrel=1
pkgdesc="An audio library based on libsndfile, CFFI and NumPy"
url="https://github.com/bastibe/PySoundFile"
arch=('any')
license=('BSD')
-makedepends=('python-setuptools' 'python2-setuptools' 'libsndfile' 'python-cffi' 'python2-cffi' 'python-numpy' 'python2-numpy')
+makedepends=('python-setuptools')
+depends=('python-cffi' 'libsndfile' 'python-numpy')
source=("https://github.com/bastibe/PySoundFile/archive/${pkgver}.tar.gz")
sha256sums=('f53fc58b943827fee60e40ee87c11d1ff21cf6567c65449897371a4019be8c28')
build() {
- cp -r "${srcdir}"/SoundFile-$pkgver "${srcdir}"/SoundFile-$pkgver-py2
-
cd "${srcdir}"/SoundFile-$pkgver
python setup.py build
-
- cd "${srcdir}"/SoundFile-$pkgver-py2
- python2 setup.py build
}
-package_python-soundfile() {
- depends=('python-cffi' 'libsndfile' 'python-numpy')
-
+package() {
cd "${srcdir}/SoundFile-$pkgver"
python setup.py install --root=${pkgdir} --optimize=1
}
-package_python2-soundfile() {
- depends=('python2-cffi' 'libsndfile' 'python2-numpy')
-
- cd "${srcdir}/SoundFile-$pkgver"
- python2 setup.py install --root=${pkgdir} --optimize=1
-}