summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJ. Nathanael Philipp2020-09-10 21:49:06 +0200
committerJ. Nathanael Philipp2020-09-10 21:49:06 +0200
commitb5952423dff67ba38f7388ae8bbf38930e622131 (patch)
tree1c6c4da53031c812d82f9c0b20d96f81039f8f26 /PKGBUILD
parent43d7be1a22b1940de588f8860932e543a4d68372 (diff)
downloadaur-b5952423dff67ba38f7388ae8bbf38930e622131.tar.gz
Add LICENSE.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1e635630c4b1..6c3248a52fef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,17 @@
pkgname=python-spacy-de_core_news_lg
pkgver=2.3.0
-pkgrel=1
+pkgrel=2
pkgdesc="German multi-task CNN trained on the TIGER and WikiNER corpora. Assigns word vectors, POS tags, dependency parses and named entities. Word vectors trained using FastText CBOW on Wikipedia and OSCAR (Common Crawl)."
url="https://spacy.io/models/de#de_core_news_lg"
depends=('python-spacy')
makedepends=('python-setuptools')
license=('MIT')
arch=(any)
-source=("https://github.com/explosion/spacy-models/releases/download/de_core_news_lg-${pkgver}/de_core_news_lg-${pkgver}.tar.gz")
-sha256sums=('cd3c565cfb6dd3df535b109077466685986059b18387259cc1fa7cf2db833d66')
+source=("https://github.com/explosion/spacy-models/releases/download/de_core_news_lg-${pkgver}/de_core_news_lg-${pkgver}.tar.gz"
+ "https://raw.githubusercontent.com/explosion/spaCy/master/LICENSE")
+sha256sums=("cd3c565cfb6dd3df535b109077466685986059b18387259cc1fa7cf2db833d66"
+ "2946c76df2417fe4e29c693e4d877f8516630740f0ede219edf1b0d06c61d536")
build() {
cd de_core_news_lg-${pkgver}
@@ -18,6 +20,7 @@ build() {
}
package() {
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
cd de_core_news_lg-${pkgver}
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}