summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilip Goto2021-02-08 15:02:42 +0100
committerPhilip Goto2021-02-08 15:02:42 +0100
commite1c169466e886ea16c837ee81518dbb1f3997381 (patch)
treee9c4ae6a3a7fef0790a87021fdcdebc918914755 /PKGBUILD
parentc8514d8024d2c6f6f134821d139c092e2ff13607 (diff)
downloadaur-e1c169466e886ea16c837ee81518dbb1f3997381.tar.gz
Update to 3.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8031fbf12d0f..05427d863b3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,24 @@
# Maintainer: Philip Goto <philip.goto@gmail.com>
pkgname=python-spacy-xx_ent_wiki_sm
-pkgver=2.3.0
+pkgver=3.0.0
pkgrel=1
-pkgdesc="Multi-lingual CNN trained on Nothman et al. (2013) Wikipedia corpus for spaCy"
+pkgdesc="Multi-lingual pretrained model for spaCy (small)"
url="https://spacy.io/models/xx#section-xx_ent_wiki_sm"
depends=('python-spacy')
makedepends=('python-setuptools')
license=('CCPL')
arch=(any)
source=("https://github.com/explosion/spacy-models/releases/download/xx_ent_wiki_sm-${pkgver}/xx_ent_wiki_sm-${pkgver}.tar.gz")
-sha256sums=('f686c0ba1c1144d7601e0c037247802bc98249ae6ee65b6c237016ba7cad7f74')
+sha256sums=('ba312602d8b7a0db141421d8c4819f85d7d06843ac2e84f9dc561b46aeda2584')
build() {
- cd xx_ent_wiki_sm-${pkgver}
- python setup.py build
+ cd xx_ent_wiki_sm-${pkgver}
+ python setup.py build
}
package() {
- cd xx_ent_wiki_sm-${pkgver}
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ cd xx_ent_wiki_sm-${pkgver}
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}