summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorUniversebenzene2023-03-12 22:00:57 +0800
committerUniversebenzene2023-03-12 22:00:57 +0800
commit0728c6fa6f798332e0872504c7d785f72568370c (patch)
treeb4789d87358a629813eb9495e2bbde85e69143ca /PKGBUILD
parentda2dd22aaad3e30ba1aa3d7879b4981c8ae3bad4 (diff)
downloadaur-0728c6fa6f798332e0872504c7d785f72568370c.tar.gz
Update to version 0.12.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e1b8f07b7ee9..ebd82d9df66e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgbase=python-sphinx-gallery
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}")
#"python-${_pyname}-doc")
-pkgver=0.12.1
+pkgver=0.12.2
pkgrel=1
pkgdesc="Sphinx extension to automatically generate an examples gallery"
arch=('any')
@@ -25,7 +25,7 @@ checkdepends=('python-pytest-cov'
# 'python-joblib'
'mayavi')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('df69258eed50f37d4eb6bf0bd4168fe3')
+md5sums=('58a41686155b33abe26648aee8e88c40')
build() {
cd ${srcdir}/${_pyname}-${pkgver}
@@ -40,13 +40,14 @@ build() {
check() {
cd ${srcdir}/${_pyname}-${pkgver}
- # require jupyterlite_sphinx, from Gentoo's ebuild
+ # require jupyterlite_sphinx, from Gentoo's ebuild. Some also cost lots of time
pytest \
--deselect=sphinx_gallery/tests/test_full.py \
--deselect=sphinx_gallery/tests/test_full_noexec.py \
--deselect=sphinx_gallery/tests/test_gen_gallery.py::test_create_jupyterlite_contents \
--deselect=sphinx_gallery/tests/test_gen_gallery.py::test_create_jupyterlite_contents_non_default_contents \
- --deselect=sphinx_gallery/tests/test_gen_gallery.py::test_create_jupyterlite_contents_with_jupyterlite_disabled_via_confi || warning "Tests failed" # -vv --color=yes
+ --deselect=sphinx_gallery/tests/test_gen_gallery.py::test_create_jupyterlite_contents_with_jupyterlite_disabled_via_confi \
+ --deselect=sphinx_gallery/tests/test_docs_resolv.py::test_embed_code_links_get_data || warning "Tests failed" # -vv --color=yes
# --deselect=sphinx_gallery/tests/test_scrapers.py::test_save_mayavi_figures || warning "Tests failed"
}