summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorUniversebenzene2020-04-23 15:56:27 +0800
committerUniversebenzene2020-04-23 15:56:27 +0800
commit6b0e236f0b6f1db7547de43b4be376c2246b635b (patch)
treea443cdee43ae0a6de5ea20b382ff763001849e43 /PKGBUILD
parent693b6b78ec5397cac9b8e1b21ab7c7fe649e6cae (diff)
downloadaur-6b0e236f0b6f1db7547de43b4be376c2246b635b.tar.gz
Update to version 0.6.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b3f15b43672d..35f099479903 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgbase=python-sphinx-gallery
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}")
#"python-${_pyname}-doc")
-pkgver=0.6.0
+pkgver=0.6.2
pkgrel=1
pkgdesc="Sphinx extension to automatically generate an examples gallery"
arch=('i686' 'x86_64')
@@ -11,9 +11,9 @@ url="http://sphinx-gallery.readthedocs.io/"
license=('BSD')
makedepends=('python-setuptools')
#'python-sphinx' 'python-pillow' 'python-scipy' 'python-seaborn')
-checkdepends=('python-pytest-cov' 'python-matplotlib' 'python-pillow' 'python-sphinx')
+checkdepends=('python-pytest-cov' 'python-matplotlib' 'python-pillow' 'python-sphinx' 'python-joblib')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('ba828b9592350147755bdc423e416f89')
+md5sums=('73584c81a5a2ef794d4055a3132bcc90')
build() {
cd ${srcdir}/${_pyname}-${pkgver}
@@ -26,13 +26,14 @@ build() {
check() {
cd ${srcdir}/${_pyname}-${pkgver}
- python setup.py test
-# pytest
+# python setup.py test
+ pytest
}
package_python-sphinx-gallery() {
- depends=('python-sphinx>=1.8.3' 'python-matplotlib' 'python-pillow')
+ depends=('python-sphinx>=1.8.3' 'python-pillow')
optdepends=('python-seaborn'
+ 'python-matplotlib'
'mayavi')
# 'python-sphinx-gallery-doc: Documentation of Sphinx-Gallery')
cd ${srcdir}/${_pyname}-${pkgver}