summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorUniversebenzene2019-11-19 01:59:44 +0800
committerUniversebenzene2019-11-19 01:59:44 +0800
commit950f2e14f038fa963b1d6a23fc778279d8a5af05 (patch)
treeec8bb80bb783e9f5368b3746a387b22df6420de7 /PKGBUILD
parent404f2e0efa859b8bd8561f219a914adf002be792 (diff)
downloadaur-950f2e14f038fa963b1d6a23fc778279d8a5af05.tar.gz
Update to version 0.5.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 8 insertions, 36 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 30f4f1a96708..f23108578823 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,21 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgbase=python-sphinx-gallery
_pyname=${pkgbase#python-}
-pkgname=("python-${_pyname}" "python2-${_pyname}")
+pkgname=("python-${_pyname}")
#"python-${_pyname}-doc")
-pkgver=0.4.0
+pkgver=0.5.0
pkgrel=1
pkgdesc="Sphinx extension to automatically generate an examples gallery"
arch=('i686' 'x86_64')
url="http://sphinx-gallery.readthedocs.io/"
license=('BSD')
-makedepends=('python-setuptools' 'python2-setuptools')
+makedepends=('python-setuptools')
#'python-sphinx' 'python-pillow' 'python-scipy' 'python-seaborn')
-checkdepends=('python-pytest-cov' 'python2-pytest-cov' 'python-matplotlib' 'python2-matplotlib' 'python-pillow' 'python2-pillow' 'python-sphinx' 'python2-sphinx')
+checkdepends=('python-pytest-cov' 'python-matplotlib' 'python-pillow' 'python-sphinx')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('1f3e578107ca253a184889733a4fbcea')
-
-prepare() {
- cp -a ${srcdir}/${_pyname}-${pkgver}{,-py2}
-}
+md5sums=('8fd322c845330921dd300e2c9b7ed235')
build() {
- msg "Building Python2"
- cd ${srcdir}/${_pyname}-${pkgver}-py2
- python2 setup.py build
-
- msg "Building Python3"
cd ${srcdir}/${_pyname}-${pkgver}
python setup.py build
@@ -34,33 +25,14 @@ build() {
check() {
cd ${srcdir}/${_pyname}-${pkgver}
- msg "Checking Python3"
- python setup.py test
-
- msg "Checking Python2"
- cd ${srcdir}/${_pyname}-${pkgver}-py2
- python2 setup.py test
-}
-
-package_python2-sphinx-gallery() {
- depends=('python2-sphinx' 'python2-matplotlib' 'python2-pillow')
- optdepends=('python2-seaborn'
- 'mayavi')
-# 'python-sphinx-gallery-doc: Documentation of Sphinx-Gallery')
- cd ${srcdir}/${_pyname}-${pkgver}-py2
- install -D -m644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
- install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
- python2 setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
-
- mv ${pkgdir}/usr/bin/copy_sphinxgallery{,2}.sh
- mv ${pkgdir}/usr/bin/sphx_glr_python_to_jupyter{,2}.py
+ python setup.py test
}
package_python-sphinx-gallery() {
- depends=('python-sphinx' 'python-matplotlib' 'python-pillow')
+ depends=('python-sphinx>=1.8.3' 'python-matplotlib' 'python-pillow')
optdepends=('python-seaborn'
- 'mayavi-py3')
+ 'mayavi')
# 'python-sphinx-gallery-doc: Documentation of Sphinx-Gallery')
cd ${srcdir}/${_pyname}-${pkgver}