summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorUniversebenzene2022-07-27 14:39:35 +0800
committerUniversebenzene2022-07-27 14:39:35 +0800
commitb0f013759d1cf134957162dad13d89c5d6f35f1a (patch)
treea6601d5a07086c4455dc373e8d92400c44310a13 /PKGBUILD
parent23de3b3def2c10dd8b3c49929bd87df0ca04278d (diff)
downloadaur-b0f013759d1cf134957162dad13d89c5d6f35f1a.tar.gz
Update to version 0.11.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 15 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 417f4d7226c9..c676591965dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,35 @@ pkgbase=python-sphinx-gallery
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}")
#"python-${_pyname}-doc")
-pkgver=0.10.1
+pkgver=0.11.0
pkgrel=1
pkgdesc="Sphinx extension to automatically generate an examples gallery"
arch=('any')
url="http://sphinx-gallery.github.io"
license=('BSD')
makedepends=('python-setuptools')
+# 'python-wheel'
+# 'python-build'
+# 'python-installer')
#'python-sphinx' 'python-pillow' 'python-scipy' 'python-seaborn')
-checkdepends=('python-pytest-cov' 'python-matplotlib' 'python-pillow' 'python-sphinx' 'python-joblib')
+checkdepends=('python-pytest-cov'
+ 'python-matplotlib'
+ 'python-pillow'
+ 'python-sphinx'
+ 'python-absl'
+ 'python-joblib'
+ 'mayavi')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('49727ee066dbeced6bfca7e89f6dc01f')
+md5sums=('c3adbd7c2e2315a72f9c8056feec2d7c')
build() {
cd ${srcdir}/${_pyname}-${pkgver}
python setup.py build
+# python -m build --wheel --no-isolation
# msg "Building Docs"
# python setup.py build_sphinx
+# PYTHONPATH="../build/lib" make html
}
check() {
@@ -40,6 +51,7 @@ package_python-sphinx-gallery() {
install -D -m644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+# python -m installer --destdir="${pkgdir}" dist/*.whl
}
#package_python-sphinx-gallery-doc() {