summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorUniversebenzene2023-04-15 13:39:28 +0800
committerUniversebenzene2023-04-15 13:39:28 +0800
commitc442580ebab317c4bc42a597ffef09e7b58ed57a (patch)
tree7af410d24a1eff8217e9140629287a5169dd7f9b /PKGBUILD
parent77acaaa066a67c1c87b8f9cdfe2b904f9a3aa22d (diff)
downloadaur-c442580ebab317c4bc42a597ffef09e7b58ed57a.tar.gz
Update to version 0.13.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c21cc6926d7c..3e0fc508a52c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgbase=python-sphinx-gallery
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}")
#"python-${_pyname}-doc")
-pkgver=0.12.2
+pkgver=0.13.0
pkgrel=1
pkgdesc="Sphinx extension to automatically generate an examples gallery"
arch=('any')
@@ -18,6 +18,7 @@ makedepends=('python-setuptools')
# 'python-scipy'
# 'python-seaborn')
checkdepends=('python-pytest-cov'
+ 'python-exceptiongroup'
'python-matplotlib'
'python-pillow'
'python-sphinx'
@@ -25,7 +26,7 @@ checkdepends=('python-pytest-cov'
# 'python-joblib'
# 'mayavi')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('58a41686155b33abe26648aee8e88c40')
+md5sums=('653078ba025b89a99171fe21417088b9')
build() {
cd ${srcdir}/${_pyname}-${pkgver}
@@ -52,7 +53,7 @@ check() {
}
package_python-sphinx-gallery() {
- depends=('python-sphinx>=3' 'python-pillow' 'python-matplotlib')
+ depends=('python-sphinx>=4' 'python-pillow' 'python-matplotlib')
optdepends=('python-seaborn'
'mayavi'
'python-pypandoc')