summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorUniversebenzene2023-08-21 15:28:12 +0800
committerUniversebenzene2023-08-21 15:28:12 +0800
commitcd098873149ea3c54446fa6d3c8fe48a9483fb5b (patch)
tree944a6c4c3bdc005a7192c778983f332fd279405a /PKGBUILD
parent2df7b5b9676fa1439ebe0b04d016db1829003d4b (diff)
downloadaur-cd098873149ea3c54446fa6d3c8fe48a9483fb5b.tar.gz
Update to version 0.14.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 14 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e24308fb4e6b..3e3676c4eb33 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,35 +3,34 @@ pkgbase=python-sphinx-gallery
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}")
#"python-${_pyname}-doc")
-pkgver=0.13.0
+pkgver=0.14.0
pkgrel=1
pkgdesc="Sphinx extension to automatically generate an examples gallery"
arch=('any')
url="http://sphinx-gallery.github.io"
license=('BSD')
-makedepends=('python-setuptools')
-# 'python-wheel'
-# 'python-build'
-# 'python-installer'
+makedepends=('python-setuptools'
+ 'python-wheel'
+ 'python-build'
+ 'python-installer')
# 'python-sphinx'
# 'python-pillow'
# 'python-scipy'
-# 'python-seaborn')
+# 'python-seaborn'
checkdepends=('python-pytest-cov'
- 'python-exceptiongroup'
'python-matplotlib'
'python-pillow'
'python-sphinx'
'python-absl')
-# 'python-joblib'
-# 'mayavi')
+# 'python-exceptiongroup'
+## 'python-joblib'
+## 'mayavi'
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('653078ba025b89a99171fe21417088b9')
+md5sums=('d66041acf34685868ec3dac471d910d5')
build() {
cd ${srcdir}/${_pyname}-${pkgver}
- python setup.py build
-# python -m build --wheel --no-isolation
+ python -m build --wheel --no-isolation
# msg "Building Docs"
# python setup.py build_sphinx
@@ -47,8 +46,8 @@ check() {
--deselect=sphinx_gallery/tests/test_full_noexec.py \
--deselect=sphinx_gallery/tests/test_gen_gallery.py::test_create_jupyterlite_contents \
--deselect=sphinx_gallery/tests/test_gen_gallery.py::test_create_jupyterlite_contents_non_default_contents \
- --deselect=sphinx_gallery/tests/test_gen_gallery.py::test_create_jupyterlite_contents_with_jupyterlite_disabled_via_confi \
- --deselect=sphinx_gallery/tests/test_docs_resolv.py::test_embed_code_links_get_data || warning "Tests failed" # -vv --color=yes
+ --deselect=sphinx_gallery/tests/test_gen_gallery.py::test_create_jupyterlite_contents_with_jupyterlite_disabled_via_config || warning "Tests failed" # -vv -l -ra --color=yes -o console_output_style=count \
+# --deselect=sphinx_gallery/tests/test_docs_resolv.py::test_embed_code_links_get_data #|| warning "Tests failed" # -vv -l -ra --color=yes -o console_output_style=count
# --deselect=sphinx_gallery/tests/test_scrapers.py::test_save_mayavi_figures || warning "Tests failed"
}
@@ -62,8 +61,7 @@ package_python-sphinx-gallery() {
install -D -m644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
- python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
-# python -m installer --destdir="${pkgdir}" dist/*.whl
+ python -m installer --destdir="${pkgdir}" dist/*.whl
}
#package_python-sphinx-gallery-doc() {