summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBruno Santos2019-01-29 01:32:15 +0100
committerBruno Santos2019-01-29 01:32:15 +0100
commitd1d437b9a907bd1d0ead189d86c909d972eea89d (patch)
tree8364f2f5ce1d69b9b11faae88d89e2666ebe524e /PKGBUILD
parent2409e2b93b4993a8447dab3bffcd410b8418d8ad (diff)
downloadaur-d1d437b9a907bd1d0ead189d86c909d972eea89d.tar.gz
Rename and transition to tagged releases
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 26a155a58c42..d58f12dff3df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,19 @@
# Maintainer: Bruno Santos <brunomanuelsantos@tecnico.ulisboa.pt>
-#
-# This package now follows a branch since there's no proper release yet. This
-# package will eventually transition to a stable release.
-pkgname=hawkmoth
-pkgver=latest
-pkgrel=2
+upstream_name=hawkmoth
+pkgname=python-sphinx-hawkmoth
+pkgver=0.2
+pkgrel=1
pkgdesc='Sphinx autodoc C extension'
arch=('i686' 'x86_64')
url='https://github.com/jnikula/hawkmoth'
license=('BSD2')
depends=('python-sphinx' 'clang')
-source=('git+https://github.com/jnikula/hawkmoth')
-md5sums=('SKIP')
+source=('https://github.com/jnikula/hawkmoth/archive/v'$pkgver'.tar.gz')
+md5sums=('2e1b15de86f85ecb4041845ff1f75b39')
package() {
dest=$pkgdir/usr/lib/python3.7/site-packages/$pkgname
mkdir -p $dest
- install $srcdir/$pkgname/$pkgname/*.py $dest
+ cp -r $srcdir/$upstream_name-$pkgver/* $dest
}