summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJeremy Gust2023-06-04 00:19:10 -0600
committerJeremy Gust2023-06-04 00:19:10 -0600
commitabdf05122909e5436f479580bd14003868de27b2 (patch)
treecc3bc41a2fc77a4684fd839d7be8541efe0f6644 /PKGBUILD
parent744cc2fd907f8f3f2e29b19cbd23018150a1b8fe (diff)
downloadaur-abdf05122909e5436f479580bd14003868de27b2.tar.gz
Updated to version 0.5.4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 22 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0f614559f698..1eec0c560269 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,28 @@
-# Maintainer: mar77i <mar77i at mar77i dot ch>
-_basepkg=sphinx-paramlinks
-pkgname="python-$_basepkg"
-pkgver=0.3.1
+# Maintainer: Jeremy Gust <jeremy AT plasticsoup DOT net>
+# Contributor: mar77i <mar77i at mar77i dot ch>
+
+pkgname="python-sphinx-paramlinks"
+_pkg="${pkgname#python-}"
+pkgver=0.5.4
pkgrel=1
-pkgdesc="Allows param links in Sphinx function/method descriptions to be linkable"
-arch=(any)
-url="https://bitbucket.org/zzzeek/$_basepkg"
+pkgdesc="Allows :param: directives within Python documentation to be linkable."
+arch=('any')
+url="https://github.com/sqlalchemyorg/sphinx-paramlinks"
license=('MIT')
depends=('python' 'python-sphinx')
-source=("https://pypi.python.org/packages/source/s/$_basepkg/$_basepkg-$pkgver.tar.gz")
-sha1sums=(8201182841728c97ba5a401a1214b85988935800)
+source=(""$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"")
+sha256sums=(a6f2b00233445285d49bb561f88b4688208cd4745113c266c18a810932aa6034)
-package() {
- cd "$srcdir/$_basepkg-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+build() {
+ cd "$_pkg-$pkgver"
+ python -m build --wheel --no-isolation
}
-
+package() {
+ cd "$_pkg-$pkgver"
+ python -m installer --destdir="$pkgdir/" dist/*.whl
+ install -Dvm644 README.rst -t "$pkgdir/usr/share/doc/$pkgname/"
+ local _site="$(python -c 'import site; print(site.getsitepackages()[0])')"
+ install -dv "$pkgdir/usr/share/licenses/$pkgname/"
+ ln -sv "$_site/${_pkg/-/_}-$pkgver.dist-info/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/"
+}