summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJakob Gahde2019-05-08 14:13:27 +0200
committerJakob Gahde2019-05-08 14:13:27 +0200
commit478618bd0941c39dbd1e0202c3579902a64a53b2 (patch)
tree0f7895b8ff0470bcb587c2e4820079509c29ae4d /PKGBUILD
parent4e35d35e82cf50039d766681fa65995c6bf99471 (diff)
downloadaur-python-sphinx1.tar.gz
python-sphinx1 1.8.5-1: New package based on python-sphinx
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 16 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 99d1fe650239..174b84611e98 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
-# Maintainer: Johannes Löthberg <johannes@kyriasis.com>
+# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
+# Contributor: Johannes Löthberg <johannes@kyriasis.com>
# Contributor: Sébastien Luttringer
# Contributor: Angel Velasquez <angvp@archlinux.org>
# Contributor: Fabio Volpe <volpefabio@gmail.com>
-pkgbase=python-sphinx
-pkgname=('python-sphinx' 'python2-sphinx')
+pkgbase=python-sphinx1
+pkgname=('python-sphinx1' 'python2-sphinx1')
pkgver=1.8.5
pkgrel=1
@@ -91,8 +92,8 @@ build() {
# rm -r tests
#}
-package_python-sphinx() {
- pkgdesc='Python3 documentation generator'
+package_python-sphinx1() {
+ pkgdesc='Python3 documentation generator (version 1)'
depends=(
'python-setuptools'
'python-jinja'
@@ -112,14 +113,17 @@ package_python-sphinx() {
optdepends=('texlive-latexextra: for generation of PDF documentation'
'imagemagick: ext.imageconverter')
+ provides=("python-sphinx=$pkgver")
+ conflicts=('python-sphinx')
+
cd Sphinx-$pkgver
python setup.py install --root="$pkgdir" --optimize=1
- install -Dm644 "$srcdir"/Sphinx-$pkgver/LICENSE "$pkgdir"/usr/share/licenses/python-sphinx/LICENSE
+ install -Dm644 "$srcdir"/Sphinx-$pkgver/LICENSE "$pkgdir"/usr/share/licenses/python-sphinx1/LICENSE
}
-package_python2-sphinx() {
- pkgdesc='Python2 documentation generator'
+package_python2-sphinx1() {
+ pkgdesc='Python2 documentation generator (version 1)'
depends=(
'python2-setuptools'
'python2-jinja'
@@ -140,10 +144,13 @@ package_python2-sphinx() {
optdepends=('texlive-latexextra: for generation of PDF documentation'
'imagemagick: ext.imageconverter')
+ provides=("python2-sphinx=$pkgver")
+ conflicts=('python2-sphinx')
+
cd Sphinx-${pkgver}2
python2 setup.py install --root="$pkgdir" --optimize=1
- install -Dm644 "$srcdir"/Sphinx-$pkgver/LICENSE "$pkgdir"/usr/share/licenses/python2-sphinx/LICENSE
+ install -Dm644 "$srcdir"/Sphinx-$pkgver/LICENSE "$pkgdir"/usr/share/licenses/python2-sphinx1/LICENSE
}
# vim:set ts=2 sw=2 et: