summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorarojas2015-07-09 17:15:41 +0000
committersvntogit2015-07-09 17:15:41 +0000
commitd154e5e1e3ce2bf16a98f78a40ff67994dba19de (patch)
treedd3a51ba642a9af3315419ccf3b4baaa4e041590 /PKGBUILD
parenta68d0843fe67c004d948f733d8ae2730eb78370c (diff)
downloadaur-d154e5e1e3ce2bf16a98f78a40ff67994dba19de.tar.gz
Also apply the patch to python2 version
git-svn-id: file:///srv/repos/svn-community/svn@136600 9fca08f4-af9d-4005-b8df-a31f2cc04f65
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e47aa2c74aeb..c584f2c5c6b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgbase=python-sphinx
pkgname=('python-sphinx' 'python2-sphinx')
pkgver=1.3.1
-pkgrel=8
+pkgrel=9
arch=('any')
url='http://sphinx.pocoo.org/'
license=('BSD')
@@ -37,6 +37,11 @@ md5sums=('8786a194acf9673464c5455b11fd4332'
'103a559a4e4a17d4dd9c3e2342486197')
prepare() {
+ # https://github.com/sphinx-doc/sphinx/pull/1892
+ pushd Sphinx-$pkgver
+ patch -p1 -i "$srcdir"/4c2f693cbf7ec40448e7237383880d701ede6c88.patch
+ popd
+
# souce duplication is required because makefile modify source code
# setyp.py --build tricks don't works well
cp -a Sphinx-$pkgver Sphinx-${pkgver}2
@@ -46,10 +51,6 @@ prepare() {
# change sphinx-binaries name in source code
find Sphinx-${pkgver}2 -type f -name '*.py' -exec \
sed -ri 's,(sphinx-(:?build|apidoc|autogen|quickstart)),\12,' {} \;
-
- # https://github.com/sphinx-doc/sphinx/pull/1892
- cd Sphinx-$pkgver
- patch -p1 -i "$srcdir"/4c2f693cbf7ec40448e7237383880d701ede6c88.patch
}
build() {