summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsL1pKn072024-05-04 19:50:29 +0200
committersL1pKn072024-05-04 19:50:29 +0200
commit9ad8ce0acc041d0aae8c6f62df32c9df6e979e82 (patch)
tree06c1dfcdd8b7d5366387236e79cd844a343fdf37 /PKGBUILD
parente13604fd0320d55f24356afdce080c046acaf4ff (diff)
downloadaur-9ad8ce0acc041d0aae8c6f62df32c9df6e979e82.tar.gz
bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 14 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f479bd7eab15..a4a1997d6ca0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,21 +8,27 @@ arch=('any')
url='https://github.com/missinglinkelectronics/sphinxcontrib-svg2pdfconverter'
license=('BSD')
depends=('python-sphinx')
-makedepends=('python-pip')
-optdepends=('librsvg: Use librsvg engine'
- 'inkscape: Use inkscape engine'
- )
+makedepends=(
+ 'python-setuptools'
+ 'python-installer'
+ 'python-wheel'
+ 'python-build'
+)
+optdepends=(
+ 'librsvg: Use librsvg engine'
+ 'inkscape: Use inkscape engine'
+)
source=("https://github.com/missinglinkelectronics/sphinxcontrib-svg2pdfconverter/archive/v${pkgver}.tar.gz")
sha256sums=('bdaca33b740261cbff41519ecbd2791c59d33b403f366636fc4f912213abe05c')
build() {
- cd "${srcdir}/sphinxcontrib-svg2pdfconverter-${pkgver}"
- pip wheel --no-deps . -w dist
+ cd "sphinxcontrib-svg2pdfconverter-${pkgver}"
+ python -m build --wheel --no-isolation
}
package() {
- cd "${srcdir}/sphinxcontrib-svg2pdfconverter-${pkgver}"
- pip install -I --root "${pkgdir}" --no-warn-script-location --no-deps dist/*.whl
+ cd "sphinxcontrib-svg2pdfconverter-${pkgver}"
+ python -m installer --destdir="${pkgdir}" dist/*.whl
install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/License.txt"
}