summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoralkeo2018-02-18 17:46:47 +0100
committeralkeo2018-02-18 17:46:47 +0100
commit23448a7ff5ccd73772ac7b7b741e5565f2a72ab3 (patch)
tree326ac74cee8877a18af796e4c8e02ef80d232683 /PKGBUILD
parent6632595bdbad200ac7f976cc7b7e5dbe1cc2b694 (diff)
downloadaur-23448a7ff5ccd73772ac7b7b741e5565f2a72ab3.tar.gz
fixed compatibility with sphinx-1.7
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e70d2b66c183..f34a696ddb7c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,26 @@
# Maintainer: Simon Boulay <simon.boulay@alkeona.net>
+# Contributor: Melvin Vermeeren <mail@mel.vin>
_name=sphinxcontrib-tikz
pkgname=("python-${_name}" "python2-${_name}")
pkgver=0.4.4
-pkgrel=1
+pkgrel=2
pkgdesc="TikZ extension for Sphinx."
arch=('any')
url="https://bitbucket.org/philexander/tikz"
license=('BSD')
makedepends=('python' 'python-setuptools' 'python2' 'python2-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('755a88072f7d3591846a3190f208d662bde84640b18bdea358a1358e895757ff')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz"
+ sphinxcontrib-tikz-sphinx1.7-fix.diff)
+sha256sums=('755a88072f7d3591846a3190f208d662bde84640b18bdea358a1358e895757ff'
+ '276e04bfbca4086331cb9a135c87af1bd8a7219aa942743cbdb398fcb3741c92')
prepare() {
- cp -a "sphinxcontrib-tikz-$pkgver" "sphinxcontrib-tikz2-$pkgver"
+ cd "sphinxcontrib-tikz-$pkgver"
+
+ patch -p1 < "${srcdir}/sphinxcontrib-tikz-sphinx1.7-fix.diff"
+
+ cp -a "${srcdir}/sphinxcontrib-tikz-$pkgver" "${srcdir}/sphinxcontrib-tikz2-$pkgver"
}
package_python-sphinxcontrib-tikz() {