summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorShane Stone2018-04-29 23:44:30 -0700
committerShane Stone2018-04-29 23:44:30 -0700
commitb9cc222fc078f0811d94b31da5fb799c15ab0f70 (patch)
tree4be78b8fe2995c4b895948806592873b14cd7d81 /PKGBUILD
parent8ebdc5a77327c44497f129a8a8be39050344c134 (diff)
downloadaur-b9cc222fc078f0811d94b31da5fb799c15ab0f70.tar.gz
Bump to v2.1.1 and remove mv command that is no longer necessary
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 9 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 150df47da066..c8926eb48d75 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,28 @@
# $Id$
# Maintainer: Shane Stone <shanewstone at gmail>
-
-pkgname=('python-spiceypy')
-pkgver=2.1.0
-pkgrel=2
+pkgname=python-spiceypy
+pkgver=2.1.1
+pkgrel=1
pkgdesc="A Python wrapper for the NAIF C SPICE Toolkit (N66) written using ctypes."
arch=('any')
url="https://github.com/AndrewAnnex/SpiceyPy"
license=('MIT')
-makedepends=('python-six>=1.9.0' 'python-numpy>=1.8.0' 'python-setuptools')
+makedepends=('python-six>=1.9.0' 'python-numpy>=1.12.0' 'python-certifi>=2017.1.23' 'python-setuptools')
+depends=('python-six>=1.9.0' 'python-numpy>=1.12.0' 'python-certifi>=2017.1.23')
+optdepends=('python-pytest>=2.9.0: testing')
source=("$pkgname-$pkgver.tar.gz::https://github.com/andrewannex/spiceypy/archive/v$pkgver.tar.gz")
-md5sums=('be29fd2060b5a61f9f3e271835e82022')
+md5sums=('a32faf9c4b76c3257329e336c15be8fd')
build() {
- echo "Building Python3"
cd SpiceyPy-$pkgver
+
python setup.py build
}
package() {
- depends=('python-six>=1.9.0' 'python-numpy>=1.8.0')
- optdepends=('python-pytest>=2.9.0: testing')
-
cd SpiceyPy-$pkgver
python setup.py install --skip-build --root="$pkgdir" --optimize=1
- mv -v $srcdir/SpiceyPy-$pkgver/spiceypy/utils/spice.so $pkgdir/usr/lib/python3*/site-packages/spiceypy/utils/
-
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
}