summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTim Schumacher2019-10-08 13:37:35 +0200
committerTim Schumacher2019-10-08 13:37:35 +0200
commitade41c6280dd5f469a8f42865cdf69044ea8a37c (patch)
treed48732bca258f297fed1432497accb4e7f6090d7 /PKGBUILD
downloadaur-ade41c6280dd5f469a8f42865cdf69044ea8a37c.tar.gz
Initial python-spotdl package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d0b26af28382
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Tim Schumacher <timschumi@gmx.de>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Gordian Edenhofer <gordian.edenhofer[at]yahoo[dot]de>
+
+pkgname=python-spotdl
+pkgver=1.2.2
+pkgrel=1
+pkgdesc="Download songs from YouTube using Spotify song URLs or playlists with albumart and meta-tags."
+arch=('any')
+license=('MIT')
+url="https://github.com/ritiek/spotify-downloader"
+depends=('python-setuptools' 'ffmpeg' 'python-lyricwikia' 'python-yaml' 'python-pathlib' 'youtube-dl' 'python-spotipy' 'python-beautifulsoup4' 'python-logzero' 'python-mutagen' 'python-unicode-slugify' 'python-pafy' 'python-appdirs' 'python-titlecase')
+source=("https://pypi.io/packages/source/s/spotdl/spotdl-$pkgver.tar.gz")
+sha512sums=('dd422d00e399f04b0f3c9ea1cfa8c26fef948bcf672a60292d573dcbde9ae3ae6b415206259efffb1e2a14c92093cfae27c4ef759c496b07f07432ba362d06a7')
+
+build() {
+ cd spotdl-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd spotdl-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1
+}
+