summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorasm0dey2019-06-24 10:25:20 +0300
committerasm0dey2019-06-24 10:25:20 +0300
commit810ba193fe1219ddd73fc65ad346644b32874c1e (patch)
tree2c805d1741ee9b713b374183400ef8746390f4f2 /PKGBUILD
downloadaur-810ba193fe1219ddd73fc65ad346644b32874c1e.tar.gz
Initial
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..36e6338636e3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: asm0dey <pavel.finkelshtein+AUR@gmail.com>
+
+pkgname=python-sqlparse-0_3_0
+_pkgname=python-sqlparse
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="A non-validating SQL parser module for Python"
+url="https://github.com/andialbrecht/sqlparse"
+arch=(any)
+license=('BSD')
+depends=('python')
+makedepends=('python-distribute')
+source=($_pkgname-$pkgver.zip::https://github.com/andialbrecht/sqlparse/archive/$pkgver.zip)
+provides=('python-sqlparse')
+conflicts=('python-sqlparse' 'pyton-sqlparse-git')
+md5sums=('44e66ecc480fd4ac1309346c98e28e5b')
+
+package() {
+ cd "$srcdir/sqlparse-${pkgver}"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ mkdir -p "$pkgdir/usr/share/licenses/$i_pkgname"
+ cp LICENSE "$_/LICENSE"
+}