summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFelix Höffken2023-09-26 11:27:19 +0200
committerFelix Höffken2023-09-26 11:27:19 +0200
commit7c82dee7410ea6f1e88e7cfe00566e6def1e6a9e (patch)
tree9f9489046ae0adf5a7c07a9c7797bb38db20649e /PKGBUILD
parent15f81d65f1a68044bb894f3fd55a6486754699d3 (diff)
downloadaur-7c82dee7410ea6f1e88e7cfe00566e6def1e6a9e.tar.gz
Remove python2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 5 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4357018c543d..7a8e88060ee6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
# Contributor: Juraj Fiala <doctorjellyface at riseup dot net
_srcname=srp
-pkgname=(python-$_srcname python2-$_srcname)
+pkgname="python-$_srcname"
pkgbase=python-srp
pkgver=1.0.19
-pkgrel=1
+pkgrel=2
pkgdesc='Python implementation of the Secure Remote Password protocol (SRP)'
arch=('any')
url="https://github.com/cocagne/py$_srcname"
license=('MIT')
-makedepends=('python' 'python2' 'python-six' 'python2-six')
+makedepends=('python' 'python-six' )
source=("$url/archive/$pkgver.tar.gz")
sha256sums=('57dd009ed4d739fa4bd7403fb014c0113621e5631953396221749ed53a9dd4a8')
@@ -22,18 +22,11 @@ prepare() {
build() {
cd "$srcdir/py$_srcname-$pkgver"
python setup.py build
-
- cd "$srcdir/py$_srcname-$pkgver-py2"
- python2 setup.py build
}
check() {
- # Test script isn’t compatible with Python 3 by the looks of it
- # cd "$srcdir/py$_srcname-$pkgver"
- # python srp/test_srp.py
-
- cd "$srcdir/py$_srcname-$pkgver-py2"
- python2 srp/test_srp.py
+ cd "$srcdir/py$_srcname-$pkgver"
+ python srp/test_srp.py
}
package_python-srp() {
@@ -43,12 +36,3 @@ package_python-srp() {
python setup.py install --skip-build --root="$pkgdir" --optimize=1
install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-
-package_python2-srp() {
- depends=('python2' 'openssl')
-
- cd "$srcdir/py$_srcname-$pkgver-py2"
- python2 setup.py install --skip-build --root="$pkgdir" --optimize=1
- install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-}
-