summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfordprefect2023-06-25 09:11:58 +0200
committerfordprefect2023-06-25 09:11:58 +0200
commitf76d0331a4acde4e73d31ad93ed04a1fb58cc84b (patch)
tree1143547a8b5cf3b4149f0a1b02d86b5fa1ed6da7 /PKGBUILD
parent9936df25151e93266efb1a71f14e2bb576a0957d (diff)
downloadaur-python-ssdeep.tar.gz
3.4.1, build update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 7 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b16d520b208e..d805b02c9511 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,21 @@
pkgname=python-ssdeep
-pkgver=3.4
+pkgver=3.4.1
pkgrel=1
pkgdesc='Python wrapper for ssdeep fuzzy hashing library'
arch=('i686' 'x86_64')
license=('LGPL3')
url='https://pypi.python.org/pypi/ssdeep'
-makedepends=('python-setuptools' 'python-pip')
+makedepends=('python-build' 'python-installer' 'python-wheel' 'ssdeep' 'python-pytest-runner')
depends=('python' 'python-cffi' 'ssdeep')
-checkdepends=('python-pytest')
source=("$pkgname-$pkgver.tar.gz::https://github.com/DinoTools/python-ssdeep/archive/${pkgver}.tar.gz")
-sha256sums=('1924ca700aedd6563b9939cac6519d5aa24c4c3c24e09a748b31c09955b09ad4')
+sha256sums=('6f984a1248ee6b434bab0e2b274621f1888d81b8241858d30f981214263b17fa')
build() {
- cd python-ssdeep-${pkgver}
- python3 setup.py build
+ cd $pkgname-$pkgver
+ python -m build --wheel --no-isolation
}
-check() {
- cd "${srcdir}"/python-ssdeep-${pkgver}
- python3 setup.py test
-}
-
package() {
- cd python-ssdeep-${pkgver}
- python3 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ cd $pkgname-$pkgver
+ python -m installer --destdir="$pkgdir" dist/*.whl
}