summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGuillaume Horel2021-04-10 11:39:09 -0400
committerGuillaume Horel2021-04-10 21:33:54 -0400
commit72bea2571c31cde915a317194856530b776936fa (patch)
tree02e6448450d2df38c4e6db241af3d1bec3658fee /PKGBUILD
parentba867fa11b0fd7c8bc3fb3e2162a9248ba73fab9 (diff)
downloadaur-72bea2571c31cde915a317194856530b776936fa.tar.gz
bump to 0.26.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 496451aa79fe..eb1450768b08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,24 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
pkgname='python-ssh2'
_pkgname='ssh2-python'
-pkgver='0.25.0'
+pkgver=0.26.0
pkgrel=1
pkgdesc="Python bindings for libssh2"
url="https://github.com/ParallelSSH/ssh2-python/"
depends=('libssh2')
makedepends=('python-setuptools' 'cython')
-checkdepends=('python-pytest')
+checkdepends=('openssh' 'python-pytest')
license=('GPL')
arch=('x86_64')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/ParallelSSH/$_pkgname/archive/$pkgver.tar.gz")
-sha256sums=('2fad2e2149ff14f17e1c2e18993624aa573f0ead8db4cb9491e0671448ccb677')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/ParallelSSH/$_pkgname/archive/$pkgver.tar.gz"
+ "fix-tests.patch")
+sha256sums=('38912993a9d63f8ec6f137d04c8eff1c840bb4b4801260a5b686e50ab57c86e7'
+ '49c6c5d2021db7a7ae5d81b7f34abd16bef06e8112d72b17a86eb8760d339f57')
+
+prepare() {
+ cd "${_pkgname}-${pkgver}"
+ patch -p0 -i ../fix-tests.patch
+}
build() {
cd "${_pkgname}-${pkgver}"