summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTomasz Żok2021-09-09 09:36:01 +0200
committerTomasz Żok2021-09-09 09:36:01 +0200
commitb53ad657f20cbcb77e878ea43c90d42f469a143c (patch)
treee2fea94b31ac18f70e75c7f72e4fb931048f0873 /PKGBUILD
downloadaur-b53ad657f20cbcb77e878ea43c90d42f469a143c.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..475fa2ddc846
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Tomasz Zok <tomasz dot zok at gmail dot com>
+pkgname=python-statham-schema
+_name=${pkgname#python-}
+pkgver=0.13.4
+pkgrel=1
+pkgdesc="Statham is a Python Model Parsing Library for JSON Schema"
+arch=(any)
+url="https://github.com/jacksmith15/statham-schema"
+license=('MIT')
+depends=(python python-pyaml python-dateutil python-jsonpointer python-json-ref-dict python-typing_extensions)
+source=("https://github.com/jacksmith15/${_name}/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('1a23b7efab98c4433df9402118e5766d974b6ec76fcdf817057de538229a8e86')
+build() {
+ cd "${_name}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${_name}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}