summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKyle Manna2016-01-11 07:36:05 -0800
committerKyle Manna2016-01-11 07:36:23 -0800
commitaa742708925c256a55443af67361d8ebbf9559b2 (patch)
tree6ca6679692bf11c2a56be3153363c0e15ed394ff /PKGBUILD
downloadaur-aa742708925c256a55443af67361d8ebbf9559b2.tar.gz
Initial release: v0.0.21
* Initial release.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1d4de478a0d9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Kyle Manna <kyle[at]kylemanna[d0t]com>
+pkgname=python-storjnode
+_pkgname=${pkgname/python-/}
+pkgver=0.0.21
+pkgrel=1
+pkgdesc="Storj core library"
+url="https://github.com/Storj/storjcore"
+depends=('python' 'python-pip' 'python-crypto' 'python-btctxstore')
+optdepends=()
+license=('MIT')
+arch=('any')
+source=("https://github.com/Storj/${_pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('f646d3b4e7ea505d29534d5758ab4c01159a3e9bb97135462b7c2808b240f817')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+ rm -rf ${pkgdir}/usr/lib/python3.4/site-packages/tests/
+}
+