summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVinicius Correa2018-05-31 11:44:55 -0300
committerVinicius Correa2018-05-31 11:44:55 -0300
commit94718a92736312d5001994ec542f2d5c166af6ff (patch)
tree70d0a95ac4c43bda7dcf87d98c5035a0eff014b9 /PKGBUILD
downloadaur-94718a92736312d5001994ec542f2d5c166af6ff.tar.gz
first
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ac1540309cab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Vinicius Correa <vinicius dot correa at zoho dot com>
+_pkgname=storm
+pkgname=python-storm
+pkgver=0.20
+pkgrel=1
+pkgdesc="An object-relational mapper (ORM) for Python"
+arch=('any')
+url="https://storm.canonical.com"
+license=('LGPL')
+depends=('python' 'python-six' 'python-future')
+makedepends=('git')
+source=("https://launchpad.net/~stoq-dev/+archive/ubuntu/stoq3/+sourcefiles/storm/0.20.0.100-2~py3-1bionic/storm_0.20.0.100-2~py3-1bionic.tar.gz")
+md5sums=('b16a6966fc5db564bdc01ed8a58cdf8e')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}.0.99"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}.0.99"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}