summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorUniversebenzene2020-04-28 17:10:32 +0800
committerUniversebenzene2020-04-28 17:10:32 +0800
commit6a2382bddded5aa71bdd77285b0938354684014a (patch)
treeb3d4ddda830f53a953b466e7e09e578fd3041520 /PKGBUILD
parentd31ce9c1286570e281c55957bd29a2ce70ab57e6 (diff)
downloadaur-6a2382bddded5aa71bdd77285b0938354684014a.tar.gz
Update to version 1.0.5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 28 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5b7b9fcd0bae..ce8e4dc3684c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,45 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgbase=python-stsci.skypac
_pyname=${pkgbase#python-}
-pkgname=("python-${_pyname}" "python-${_pyname}-doc")
-pkgver=1.0.4
+pkgname=("python-${_pyname}")
+# "python-${_pyname}-doc")
+pkgver=1.0.5
pkgrel=1
pkgdesc="Sky matching for image mosaic"
arch=('i686' 'x86_64')
url="https://stsci-skypac.readthedocs.io/"
license=('BSD')
-makedepends=('python-setuptools' 'python-relic' 'python-spherical_geometry' 'python-stsci.tools' 'python-stwcs' 'python-stsci.imagestats' 'python-numpydoc' 'python-sphinx_rtd_theme' 'python-stsci_rtd_theme')
-#checkdepends=('python-pytest')
+makedepends=('python-setuptools-scm' 'python-pytest-runner')
+#'python-stsci.tools' 'python-stsci_rtd_theme')
+#'python-spherical_geometry' 'python-stsci.tools' 'python-stsci.imagestats' 'python-numpydoc' 'python-sphinx_rtd_theme' 'python-stwcs' 'python-stsci.imagestats')
+checkdepends=('python-pytest-doctestplus' 'python-pytest-cov' 'python-codecov' 'python-spherical_geometry' 'python-stwcs' 'python-stsci.imagestats')
source=("https://github.com/spacetelescope/stsci.skypac/archive/${pkgver}.tar.gz")
-md5sums=('ef209b3328e4009d59fbcd766e2ef540')
-_pyver=$(python -V | cut -c 8-10)
+md5sums=('5fe3fc818628f706d83b51f6ddfd9cd2')
+
+prepare() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${pkgver}
+ export _pyver=$(python -V | cut -c 8-10)
+}
build() {
cd ${srcdir}/${_pyname}-${pkgver}
python setup.py build
- msg "Building Docs"
- python setup.py build_sphinx
+# msg "Building Docs"
+# cd ${srcdir}/${_pyname}-${pkgver}/docs
+# #PYTHONPATH="./build/lib" python setup.py build_sphinx
+# PYTHONPATH="../build/lib" make html
}
#check() {
# cd ${srcdir}/${_pyname}-${pkgver}
#
# python setup.py test
+## pytest
#}
-package_python-stsci.skypac() {
- depends=('python>=3.5' 'python-astropy>=3.1' 'python-spherical_geometry' 'python-stwcs' 'python-stsci.imagestats')
+package() {
+ depends=('python>=3.5' 'python-astropy>=3.1' 'python-spherical_geometry>=1.2.2' 'python-stwcs' 'python-stsci.imagestats')
optdepends=('python-stsci.skypac-doc: Documentation for STScI skypac')
cd ${srcdir}/${_pyname}-${pkgver}
@@ -40,10 +50,11 @@ package_python-stsci.skypac() {
rm "${pkgdir}/usr/lib/python${_pyver}/site-packages/stsci/__pycache__"/*
}
-package_python-stsci.skypac-doc() {
- pkgdesc="Documentation for STScI skypac"
- cd ${srcdir}/${_pyname}-${pkgver}/build/sphinx
-
- install -d -m755 "${pkgdir}/usr/share/doc/${pkgbase}"
- cp -a html "${pkgdir}/usr/share/doc/${pkgbase}"
-}
+#package_python-stsci.skypac-doc() {
+# pkgdesc="Documentation for STScI skypac"
+# cd ${srcdir}/${_pyname}-${pkgver}/build/sphinx
+#
+# install -D -m644 -t "${pkgdir}/usr/share/licenses/${pkgname}" ../../LICENSE.txt
+# install -d -m755 "${pkgdir}/usr/share/doc/${pkgbase}"
+# cp -a html "${pkgdir}/usr/share/doc/${pkgbase}"
+#}